Jump to content



Sign up for a free account to remove the pop-up ads

Signing up for an account is fast and free. As a member you can join in the conversation, enter contests and remove the pop-up ads that guests get. Click here to create your free account.

Photo
- - - - -

Sony STR-DH710 Multi Channel AV receiver wont turn on!


  • You cannot start a new topic
  • Please log in to reply
1 reply to this topic

#1 of 2 OFFLINE   GordationNation

GordationNation

    Auditioning



  • 1 posts
  • Join Date: Jan 15 2013

Posted January 15 2013 - 05:48 PM

Hi guys, Hopefully someone can help me out. I purchased my receiver a few months ago on-line and it has been working great till the other day, when i had music on, close to its max output for sound.. left the room and came back a few minutes later and it was turned off. tried turning it back on and i would hear the "click" to sound like it turned on but no lights or indication it is actually turning on. I'm guessing it was the fuse or something that killed it but hoping someone can help me diagnose the problem and tell me if its worth it to look into getting it repaired. i realize it was stupid to play it so loud and leave ha, but i thought it could handle it. guess I'll no for next time. thanks guys, any input would help! Jordan,

#2 of 2 OFFLINE   Brainwasher

Brainwasher

    Stunt Coordinator



  • 168 posts
  • Join Date: Dec 21 2012
  • Real Name:Luke
  • LocationSouthern California

Posted January 15 2013 - 06:11 PM

Your AVR may be in "protect" mode. On sony's, you hold the power button down for 5-6 seconds. This will reset it, if it doesn't work, I would call Sony. You should have a year from manufacturer.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users