-

Jump to content



Sign up for a free account!

Signing up for an account is fast and free. As a member you can join in the conversation, enter contests and you won't get the popup ads that guests get. Click here to create your free account.

Photo
- - - - -

Panasonic SC-BTT190, no Dolby 5.1


  • You cannot start a new topic
  • Please log in to reply
6 replies to this topic

#1 of 7 RevvinKevin

RevvinKevin

    Auditioning

  • 4 posts
  • Join Date: Dec 09 2012

Posted December 09 2012 - 09:07 AM

I recently bought an LG 42" LS575T and a Panasonic SC-BTT190 BluRay/Surround sound kit. I've managed to get the TV and the Freeview box working through ALL external speakers no problem. However, if I play a DVD with DTS or THX I can get sound out of all speakers. If I play a DVD with Dolby it only plays through the front speakers. I've not tried a BluRay disc yet. I've tried checking on the internet what I need to do but people get bogged down in technical jargon and I can't fathom what they are on about. Also the manual is written in complete gobbledegook. I've not got a great deal of hair left but the little I have is now getting torn out in chunks. So, in simple terms, what do I need to change, set, switch or hit to get a DVD to play through all speakers as it is supposed to. Thanks in advance. Kevin

#2 of 7 schan1269

schan1269

    HTF Expert

  • 13,184 posts
  • Join Date: Jul 04 2012
  • Real Name:Sam
  • LocationChicago-ish/NW Indiana

Posted December 09 2012 - 12:21 PM

Press the green surround button. Since it is a craptastic HTiB it probably isn't smart enough to change its own sound modes.

#3 of 7 RevvinKevin

RevvinKevin

    Auditioning

  • 4 posts
  • Join Date: Dec 09 2012

Posted December 09 2012 - 11:25 PM

Thanks for that but I've pressed the surround button, I can see the display change from 2channel to surround but still nothing comes out of the rear speakers. If I press the option button while a DVD is playing I can access the sound controls but these only say something like ENG 1 There is no reference to Dolby being available, however when a DTS one is playing DTS shows in the drop down menu.

#4 of 7 schan1269

schan1269

    HTF Expert

  • 13,184 posts
  • Join Date: Jul 04 2012
  • Real Name:Sam
  • LocationChicago-ish/NW Indiana

Posted December 10 2012 - 04:28 AM

I'm not downloading the manual for that, but... Sounds like you haven''t set it up for "what to do for 5.1 Dolby Digital"...

#5 of 7 RevvinKevin

RevvinKevin

    Auditioning

  • 4 posts
  • Join Date: Dec 09 2012

Posted December 10 2012 - 06:38 AM

It looks like I've sorted it. I messed around with the audio settings. I changed Digital Audio Output from bitstream to PCM and changed BD-Video Secondary Audio to Off. Dolby DVDs and DTS DVDs now play through all speakers. Thanks for responding anyway, much appreciated.

#6 of 7 Jason Charlton

Jason Charlton

    Screenwriter

  • 2,860 posts
  • Join Date: May 16 2002
  • Real Name:Jason Charlton
  • LocationBaltimore, MD

Posted December 10 2012 - 06:57 AM

Originally Posted by RevvinKevin 

It looks like I've sorted it. I messed around with the audio settings.
I changed Digital Audio Output from bitstream to PCM and changed BD-Video Secondary Audio to Off.
Dolby DVDs and DTS DVDs now play through all speakers.
Thanks for responding anyway, much appreciated.


Just for giggles, leave "secondary audio" set to "off" but change PCM back to Bitstream and see if that still works.


When secondary audio is turned on, the player "mixes" audio from the player menus (button clicks and such) as well as some audio commentary tracks in with the main program audio.  The players aren't always able to preserve the Dolby encoding when doing this mixing, which is probably why you were having problems.


If Bitstream and secondary audio set to off still results in problems, then by all means leave the audio output set to PCM.


Are you new to the Home Theater Forum? Stop by the New Member Introductions area and introduce yourself! See you there!


#7 of 7 RevvinKevin

RevvinKevin

    Auditioning

  • 4 posts
  • Join Date: Dec 09 2012

Posted December 10 2012 - 07:33 AM

Thanks Jason, next time I'm in the mood to get frustrated I'll try it. For now, provided all discs I throw at the player come out of all speakers and things appear to fly past my ears I'm happy. :) Next stop, try a BluRay disc..........




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users