Jump to content



Sign up for a free account to remove the pop-up ads

Signing up for an account is fast and free. As a member you can join in the conversation, enter contests and remove the pop-up ads that guests get. Click here to create your free account.


Photo
- - - - -

Planet of the Apes Boxset Rot?


  • You cannot start a new topic
  • Please log in to reply
1 reply to this topic

#1 of 2 OFFLINE   Mark Zimmer

Mark Zimmer

    Producer



  • 4,269 posts
  • Join Date: Dec 31 1969

Posted February 05 2012 - 05:12 AM

My Blu-ray set of the Planet of the Apes movies played fine probably a year ago. I pulled it out the other day and the first movie would only play after three attempts. Beneath wouldn't play at all--the copyright notice comes up, and the animated introduction, and then nothing. I found an inexpensive used copy of Beneath to replace it, and it wouldn't play either. Are these discs falling victim to rot? Anyone else had problems with these? I assume there's no recourse at this point, but still annoying. My Sony player insists the firmware is all up to date. I tried it on my laptop with blu-ray drive and it says there's no disc in the tray.

#2 of 2 OFFLINE   Richard--W

Richard--W

    Producer



  • 3,527 posts
  • Join Date: Jun 20 2004

Posted February 05 2012 - 10:10 PM

Wish I could help. Fox repackaged the set: http://www.amazon.co...8526562&sr=1-13 I bought it a couple of weeks ago, but I've no reason to think the discs aren't the same from the original set.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users