-

Jump to content



Photo
- - - - -

Panasonic PT-AE4000U - Dust Spec imperfection on screen?


This topic has been archived. This means that you cannot reply to this topic.
1 reply to this topic

#1 of 2 OFFLINE   LordX

LordX

    Extra

  • 18 posts
  • Join Date: Jan 30 2009

Posted January 29 2012 - 01:22 PM

Hey all - I just bought a Panasonic PT-AE4000U Projector a few weeks ago. (Less than 2 weeks up and running!). I finally got all the initial glitches sorted out - and now am sitting down to finally truly enjoy the unit. While watching something very bright - I noticed a spec on the screen. I went up to the screen to brush it off - it is NOT on the screen. My next move was to examine the area between the PJ and the screen (dangling spider?) and the area was clean. I even brushed off the lens on the PJ to no avail. When I look at the lens - it looks like there are many glass surfaces - not just the one I can wipe. How can I clean this? And is this something I should be concerned with in a NEW Pj? Also - I had an old PJ for 4 years in the same room - never had this issue. Thanks for any info! PS - What material/cleaning solution would you guys recommend to clean the lens itself? I do NOT want to smudge or damage the unit of course - nor do I want to leave MORE residue than before it was cleaned.

#2 of 2 OFFLINE   Jim Mcc

Jim Mcc

    Producer

  • 3,710 posts
  • Join Date: Feb 11 2004
  • Real Name:Jim
  • LocationOconomowoc, WI.

Posted January 29 2012 - 03:49 PM

It sounds like it's a "dust blob" inside the projector. It may have to be taken apart to clean it. I would Pan. and see what they say. To clean the lens, I recommend the "Lens Pen". I bought mine at Art's Cameras.