Jump to content



Sign up for a free account!

Signing up for an account is fast and free. As a member you can join in the conversation, enter contests to win things like this Logitech Harmony Ultimate Remote and you won't get the popup ads that guests get. Click here to create your free account.

Photo
- - - - -

PC sound card SPDIF digital output playback is CPU sensitive


  • You cannot start a new topic
  • Please log in to reply
2 replies to this topic

#1 of 3 yurypal

yurypal

    Auditioning

  • 3 posts
  • Join Date: Nov 07 2011

Posted November 07 2011 - 04:48 AM

Hi guys! My connection is: Rocketfish 7.1 sound card installed on PC (dual-core 3.16Ghz CPU, 4GB RAM) running Windows7 (ultimate edition) connected via SPDIF digital interface to ONKYO TX-NR709 AV-receiver. Problem: when playing music of any quality using any type of media player (tried VLC, Windows Media Player, iTunes, Foobar2000) the sound produced is somewhat extremely sensitive to any CPU activity. If I put some music playing and then open a browser, then playback gets judder, slows down, just like if my PC would interrupt the playback thread for some more "important" task. What's interesting: I don't notice this thing when watching movies! DTS sound - no problem. However, I don't do anything else at the same time when watching movies, but music listening really sucks. In fact, I might not even do anything and leave PC idle (only music player active), but any occasional activity on CPU that occurs naturally there, causing music to judder. WHY? I'm wondering what's causing it? - The dual-core CPU is more than enough to produce stable playback and RAM is sufficient. Task manager indicates barely noticeable 5% CPU load spikes. I tried to set the music player task priority to HIGH (it won't allow real time) - doesn't help. - Sound card is quite crappy though, but since playback reacts on CPU load, I can't suspect the Rocketfish to be responsible (nor receiver). - Some specific windows sound settings? Does anybody have a clue, how to get thing fixed? Thanks in advance!

#2 of 3 mattCR

mattCR

    Lead Actor

  • 9,987 posts
  • Join Date: Oct 05 2005
  • Real Name:Matt
  • LocationOverland Park, KS

Posted November 07 2011 - 05:07 AM

Ok, a few things to check:


(1) this is the baseline X-Fi card, which means that it uses CPU to handle overlays.  If you're using overlays (ie any after effects) then it will be CPU intensive.

(2) Make sure you are using the latest drivers.



trakt.tv

Ask Me about HTPC! (Threads in HTPC / PMs always responded to)

This signature is povided by MediaBrowser 3 Trakt Plugin: Media Browser 3


#3 of 3 yurypal

yurypal

    Auditioning

  • 3 posts
  • Join Date: Nov 07 2011

Posted November 09 2011 - 05:18 AM

Thanks for quick reply! Yes, first thing I did, updated the drivers, but no improvement. So it's got to be Sound card chip which is so incapable, you think. That's truely the most probable reason. I had plan of replacing the card, so there is a good reason for that now. I'll update the post after upgrade for those who might have similar issue.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users