Jump to content



Sign up for a free account!

Signing up for an account is fast and free. As a member you can join in the conversation, enter contests to win things like this Logitech Harmony Ultimate Remote and you won't get the popup ads that guests get. Click here to create your free account.

Photo
- - - - -

Paradigm PDR-10 sub appears to have a rattle in it - How to fix?


  • You cannot start a new topic
  • Please log in to reply
8 replies to this topic

#1 of 9 flycaster

flycaster

    Stunt Coordinator

  • 90 posts
  • Join Date: Jun 18 2009

Posted August 20 2010 - 10:50 AM

Have this 8 year old Paradigm sub that appears to ahve a rattle in it when I turn it's volume up.  I really don't play it hard at all and the rattle does usrprise me.  Anyone hazzard a guess as to where rattles are most likely to be? Should I try to take it apart (how?), or just let it be?



#2 of 9 Robert_J

Robert_J

    Lead Actor

  • 8,051 posts
  • Join Date: Aug 22 2000
  • Real Name:Robert
  • LocationMississippi

Posted August 20 2010 - 02:56 PM

Check and make sure the foam is not deteriorating or coming loose from the cone or frame.  The dust cap may be coming loose from the cone.  Make sure all of the screws holding the driver in are tight.


#3 of 9 flycaster

flycaster

    Stunt Coordinator

  • 90 posts
  • Join Date: Jun 18 2009

Posted August 20 2010 - 10:16 PM

Can these checks be made without opening the speaker?  If need to open speaker, just undo the screws, eh?  Also, let's say I do find deterioration around the cones, can this be fixed?



#4 of 9 Robert_J

Robert_J

    Lead Actor

  • 8,051 posts
  • Join Date: Aug 22 2000
  • Real Name:Robert
  • LocationMississippi

Posted August 21 2010 - 01:52 AM

Yes.  This is a visual inspection of the outside of the driver.  If there is a grill, you must remove it but that is all you need to do.  If this doesn't find a problem, then you will have to remove the driver.  A working knowledge of a screwdriver is required.

 

Again, yes.  If the surround is rotting away, it can be repaired.  Parts Express and dozens of other places offer refoam services from $20 to $100.  I've refoamed 4 subs recently and working on two others now.  Cost for the four 15's was $20 ($5 each) and the 12's will be $3 each.  Ebay has a few foam sellers with great prices and it is extremely easy to do.



#5 of 9 flycaster

flycaster

    Stunt Coordinator

  • 90 posts
  • Join Date: Jun 18 2009

Posted August 21 2010 - 03:48 AM

Thanks, Robert.  I'll try to get to it today to see what the problem is.  And if i see anything that's deteriorated or needs repair, I'll let you know for further advice.



#6 of 9 flycaster

flycaster

    Stunt Coordinator

  • 90 posts
  • Join Date: Jun 18 2009

Posted August 21 2010 - 07:52 AM

Think I fixed it.  First tried to remove the front panel...wouldn't budge.  Next undid the back and noted that the speaker, it self, seemed to be OK, but wires were dangling.  Taped up the wires and securely rescrewed in the back cover.  Rattle seems to be gone...for now.



#7 of 9 Robert_J

Robert_J

    Lead Actor

  • 8,051 posts
  • Join Date: Aug 22 2000
  • Real Name:Robert
  • LocationMississippi

Posted August 22 2010 - 02:28 AM

What was the wire rattling against?



#8 of 9 flycaster

flycaster

    Stunt Coordinator

  • 90 posts
  • Join Date: Jun 18 2009

Posted August 22 2010 - 03:56 AM



 

Originally Posted by Robert_J 

What was the wire rattling against?

I'm not sure, but when I lifted out the back cover (it held all the electronics), there were 2-4 wires going from it to the speaker, itself.  Those wires could have been vibrating against themselves or against the speaker, or against the sound tube???  But in any event, I just taped the wires together and to the speaker so that they didn't have a chance to vibrate.  Seems to have worked.

 



#9 of 9 Robert_J

Robert_J

    Lead Actor

  • 8,051 posts
  • Join Date: Aug 22 2000
  • Real Name:Robert
  • LocationMississippi

Posted August 22 2010 - 11:29 AM

The back "cover" is called a plate amp.  The "sound tube" is the port.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users