Jump to content



Sign up for a free account to remove the pop-up ads

Signing up for an account is fast and free. As a member you can join in the conversation, enter contests and remove the pop-up ads that guests get. Click here to create your free account.

Photo
- - - - -

General Audio sync, and loss of audio on switching input


This topic has been archived. This means that you cannot reply to this topic.
No replies to this topic

#1 of 1 OFFLINE   gordol

gordol

    Auditioning



  • 1 posts
  • Join Date: Jun 27 2010

Posted June 27 2010 - 06:03 AM

I have a home-built HT:


DVD:  Sony DVP-NC85h 5-disk carousel
reciever: Yamaha RX-V620
DVR: Motorola DCX3400
TV:  Toshiba Regza 32HL67US
BD: Samsung BD-P1600

WinXP Pro computer

No-name HDMI switch

Logitech Harmony remote 670


The way it WAS setup was that the DVR and BD connect via HDMI directly to the TV, the DVD and PC via an HDMI switch to the TV (PC uses a DVI-to-HDMI conversion cable), with audio from the PC via optical directly to the receiver, and audio from the others through the HDMI interface to the TV which then fed via optical to the receiver.


Due to audio sync issues, some real and some possibly only perceived, I've been futzing around with the audio connections.  I had changed the audio setup to feed everything directly into the receiver, all optical except for the DVR which was fed via coax digital.  This appeared to have cured the sync issue for all, except that the sync seems to have gotten worse for the DVR - a minor sync issue where the video led the audio turned into a larger sync issue where the audio led the video.


So I removed the coax digital and fed the audio via the TV for that one source.  Due to limitations on how many optical inputs the receiver has, I had to move the PC audio to the receiver's 6-channel input: Using the soundcard's speaker output jacks connecting to the receiver's "external decoder" input set.  The DVR's audio is now back to a minor sync issue of the video leading the audio.  But now, I have another problem, one that is perplexing me:


When I switch sources from the PC to the DVR, I lose my audio.


One of the weird things about the Yamaha is that the 6ch input is a toggle.  So to switch to another audio input it has to be turned off in addition to the other source selected.  I do have my Harmony remote set to toggle it when switching out of the PC source.  This does work if I switch to the DVD, but not when I switch to the DVR.  I have not (yet) tried switching from the PC to the BD.  If I swtich from PC to DVR to DVD, I get the DVD audio.  If I then switch back to the DVR, I lose the audio.  If I switch from the PC to the DVD to the DVR, I retain audio all the way.  It appears that the problem exists only when going from the PC to the DVR.  If I toggle the receiver's power after switching to the DVR, I regain my audio.


One more note about the input sourcing, just in case it matters:  the DVR is sourcing through the input labeled "MD/CD-R", the DVD through the input labeled "DVD" and the BD through the input labeled "D-TV/Cable"