Jump to content



Sign up for a free account to remove the pop-up ads

Signing up for an account is fast and free. As a member you can join in the conversation, enter contests and remove the pop-up ads that guests get. Click here to create your free account.

Photo

2005 GM Install issue


  • You cannot start a new topic
  • Please log in to reply
2 replies to this topic

#1 of 3 OFFLINE   DaveMcS

DaveMcS

    Second Unit



  • 317 posts
  • Join Date: Jan 30 2001

Posted June 28 2007 - 02:45 AM

2005 Chevy Venture....Circuit City tried to install three SIR-GM1's. One was mine (Crutchfield) and two were off their shelves. Two of the Sirius units were never recognized by the GM head unit. One actually briefly showed "UPDATING" on channel 184 when we unplugged and replugged the radio itself..then it did nothing. At no time did the other two ever display SR1 or SR2..or even show any sign of the head unit detecting the GM1.... The HU has the BAND/CD-AUX button so it SHOULD work as a plug n play unit..and one of the units DID briefly seem to show some satellite life. The Venture did NOT have XM installed at the factory..so maybe the AUX input needs to be activated by the dealer? I dunno..anyone have experience or suggestions? Thanks David.

#2 of 3 OFFLINE   Jeff Gatie

Jeff Gatie

    Lead Actor



  • 6,531 posts
  • Join Date: Aug 19 2002

Posted June 28 2007 - 06:48 AM

Scanning the various forums, it looks like you have to have the dealer reprogram the "BCM" (whatever that is) in order to activate the sat radio option if you are not swapping for an XM. If you had XM previously operating, the SIR-GM1 would just be a simple swap.

#3 of 3 OFFLINE   DaveMcS

DaveMcS

    Second Unit



  • 317 posts
  • Join Date: Jan 30 2001

Posted June 28 2007 - 07:54 AM

Thanks Jeff. I'll try and stop by and see if they wil do this for a modest fee. I hear it can be $90 to do this though! Dave




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users