Jump to content



Sign up for a free account to remove the pop-up ads

Signing up for an account is fast and free. As a member you can join in the conversation, enter contests and remove the pop-up ads that guests get. Click here to create your free account.


Photo
- - - - -

HT receiever will not stay on. Please help.


  • You cannot start a new topic
  • Please log in to reply
1 reply to this topic

#1 of 2 OFFLINE   Clint B

Clint B

    Second Unit



  • 319 posts
  • Join Date: Jul 14 2001

Posted December 10 2006 - 04:29 PM

Hi, folks. I've got a Yamaha RX-V596 5.1 receiver...it's about 3 years old. I went to fire it and a CD up earlier today and some problems ensued. At first the CD played, but I noticed I had little to no bass coming out. I then figured that someone didn't hook up the subwoofer correctly, which is vital for me because I have a sub/sat system. Anyway, I went to hook up the subwoofer, but stupidly I didn't turn off the power to anything. While it seemed like everything hooked up just fine, now when I turn on my reciever it will stay on for about 2 seconds and then automatically shut off. I've tried unplugging and replugging power cords and the subwoofer cable, and I tried shutting off the surge protector and then turning it back on after about 30 seconds. Nothing is working. There were no weird noises, the receiver wasn't hot, and there was no smoke billowing, so I'm not sure what it could be (maybe a fuse, but I don't know). Does anyone have a suggestion on what this might be and what it may take to fix it? I know a bit about this stuff, but not too much, so please try not to be too technical in your reply. Thanks for any help you can give.

#2 of 2 OFFLINE   ChrisWiggles

ChrisWiggles

    Producer



  • 4,791 posts
  • Join Date: Aug 19 2002

Posted December 11 2006 - 07:05 AM

Check all the speaker wire connections. It's possible there's a strand shorting out somewhere and causing the receiver to shut off to protect itself.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users