Jump to content



Sign up for a free account!

Signing up for an account is fast and free. As a member you can join in the conversation, enter contests to win things like this Logitech Harmony Ultimate Remote and you won't get the popup ads that guests get. Click here to create your free account.

Photo
- - - - -

Sub Amp Humming


This topic has been archived. This means that you cannot reply to this topic.
6 replies to this topic

#1 of 7 JakeMcM

JakeMcM

    Stunt Coordinator

  • 145 posts
  • Join Date: Feb 19 2003

Posted October 20 2005 - 10:18 AM

My sub has a constant hum even when it is not hooked up to anything except being plugged into the wall. I tried using a cheater plug, plugging into different outlets, different houses. I'm thinking the amp might be bad. Problem is that this is a DIY Tempest sub i bought 3 or 4 years ago and I can't remember the guys name lol. I know its not under warranty but i'm hoping he could help me fix it. His name is Darren I believe and lives in Washington State. I am pretty sure its a Parts express amp. Would it be possible to order one and replace it myself? Any help on this issue would be appreciated. Thanks.

#2 of 7 JakeMcM

JakeMcM

    Stunt Coordinator

  • 145 posts
  • Join Date: Feb 19 2003

Posted October 20 2005 - 11:14 AM

I found Darren Thomas's info and e-mailed him with the problem.

#3 of 7 JakeMcM

JakeMcM

    Stunt Coordinator

  • 145 posts
  • Join Date: Feb 19 2003

Posted October 20 2005 - 04:48 PM

Darren is trying to figure out what this could be. Anyone have any ideas?

#4 of 7 Stephen Hopkins

Stephen Hopkins

    Screenwriter

  • 2,598 posts
  • Join Date: Jul 19 2002

Posted October 21 2005 - 06:54 AM

I had a PE 272w amp that developed a hum and after a couple of months shorted out, smoked, and died. Luckily it didn't hurt my driver. I replaced it w/ a 300w digital BASH amp from PE and have been pretty happy with it.

#5 of 7 JakeMcM

JakeMcM

    Stunt Coordinator

  • 145 posts
  • Join Date: Feb 19 2003

Posted October 22 2005 - 05:04 PM

yeah i'm going to replace mine pretty soon

#6 of 7 Wayne A. Pflughaupt

Wayne A. Pflughaupt

    Producer

  • 5,910 posts
  • Join Date: Aug 05 1999

Posted October 23 2005 - 08:19 AM

Quote:
Darren is trying to figure out what this could be. Anyone have any ideas?
I think your assessment is correct, that it’s bad. It shouldn’t hum with nothing else plugged into it.

Regards,
Wayne A. Pflughaupt

My Equipment List
“A nice mid-fi system,” according to an audiophile acquaintance.

My Tech / DIY Articles and Reviews

#7 of 7 Patrick D

Patrick D

    Stunt Coordinator

  • 65 posts
  • Join Date: Jun 13 2001

Posted October 24 2005 - 12:25 PM

Is the hum loud? Is it coming from the amp or the driver? My PE amp always hummed, but it wasn't obnoxious unless you were sitting right next to it in a quiet room.

Could it be noise from a dimmer or other components in the house or noise on the line?