-

Jump to content



Sign up for a free account!

Signing up for an account is fast and free. As a member you can join in the conversation, enter contests and you won't get the popup ads that guests get. Click here to create your free account.

Photo

Batman Begins Deluxe edition problematic


This topic has been archived. This means that you cannot reply to this topic.
50 replies to this topic

#1 of 51 DanRevill

DanRevill

    Agent

  • 46 posts
  • Join Date: Aug 23 2001

Posted October 18 2005 - 03:14 PM

I have a JVC TH-A35 DVD player and I've never experienced any problems with it since I bought it last summer. Anyhow, I bought the Deluxe Edition of Batman Begins today. I came home and put it in, and during the first few minutes it froze up.

So I went back to the store (Best Buy) where I bought it, but they had none left, so I have to wait for their next shipment later this week before an exchange.

Anyhow, I decided to try the disc again, and it worked the second time around until the layer change halfway through. It didn't freeze up as bad as the last time, but it did stop a few times for a second or two.

When it was freezing, what I noticed was that the horizontal seemed to go a little sketchy and my player made like it was thinking a little harder than usual. I haven't cleaned my machine since I bought it, so perhaps that's an issue. Should I try that first before getting the exchange? Or have others experienced problems with the disc?

Thanks in advance.
You were right about the stars,
Each one is a setting sun.

#2 of 51 alan halvorson

alan halvorson

    Screenwriter

  • 2,021 posts
  • Join Date: Oct 02 1998

Posted October 18 2005 - 06:47 PM

First of all - don't clean your machine. It's one rare player that needs cleaning. Second, have you played the disc on another machine? That is always the first thing you should do.
They're coming to take me away, ha-haaa!!
They're coming to take me away, ho-ho, hee-hee, ha-haaa To the funny farm. Where life is beautiful all the time and I'll be happy to see those nice young men in their clean white coats and they're coming to take me away, ha-haaa!!!!!
- Napoleon XIV

#3 of 51 Ronald Epstein

Ronald Epstein

    Studio Mogul

  • 39,311 posts
  • Join Date: Jul 03 1997

Posted October 18 2005 - 10:59 PM

Dan,

Sorry to hear about your playback woes.

I'll watch my copy today on a Panasonic RP91 to
see if there are any problems....

...but I agree with Alan's post above that in MOST
cases defective playback is limited to a particular
player rather than being widespread.

Let's wait a few more days for other members to
receive their copies and report back as to any
potential problems.

Ronald J Epstein
Home Theater Forum co-owner

 

gallery_269895_23_10043.jpg Click Here for the latest/hottest Blu-ray Preorders gallery_269895_23_1316.jpg Click Here for our complete Blu-ray review archive

gallery_269895_23_773.jpg Click Here for our complete 3D Blu-ray review archive gallery_269895_23_992.jpgClick Here for our complete DVD review archive

gallery_269895_23_7246.jpg Click Here for Blu-Ray Preorder Release Schedule gallery_269895_23_3120.jpg Click Here for forum posting rules and regulations


#4 of 51 JoePassmore

JoePassmore

    Stunt Coordinator

  • 94 posts
  • Join Date: Oct 18 2005

Posted October 19 2005 - 12:02 AM

I've had problems on my Toshiba SD-2815. It will freeze for a few seconds, then skip ahead in 10-15 second intervals. I rented the single disc version on Monday and it started at the layer change, and again nearer to the end of the movie. Again it happened when I was watching disc 2 of my purchased deluxe version last night.Posted Image Posted Image

#5 of 51 Brett_B

Brett_B

    Supporting Actor

  • 717 posts
  • Join Date: Oct 26 1999

Posted October 19 2005 - 12:15 AM

No problems here on the Sony DVPS-7000. The movie played from beginning to end without incident.

#6 of 51 RogerH

RogerH

    Supporting Actor

  • 877 posts
  • Join Date: Oct 28 2004

Posted October 19 2005 - 12:51 AM

No problems on my Panasonic RV32

#7 of 51 nickGreenwood

nickGreenwood

    Second Unit

  • 494 posts
  • Join Date: Dec 13 2004

Posted October 19 2005 - 01:48 AM

I can't imagine the Deluxe Edition would be a different disc that the Single disc version or the double disc without the comic book version. See if a friend picked up the movie and try it on your player. Or rent it or Netflix it, see if it really is the disc or the player.

I've had no problems on my laptop nor my Panasonic VCR/DVD combo (don't remember the model number right off hand).

Good luck!
-Nick G.

"The number of people whose permission I need before I can do whatever the hell I want..." - Josh Lyman

#8 of 51 Brent Avery

Brent Avery

    Supporting Actor

  • 699 posts
  • Join Date: Feb 19 2002

Posted October 19 2005 - 01:59 AM

Watched it last night ( Deluxe version ) on a Bravo D1 via the dvi output and this player is well known for freeezing etc. but it played the disc without any problems. I frequently view alot of material on a 27" tv but in this case the 107" screen with front projection seemed to be the better choice. Posted Image And what a great image for SD.

#9 of 51 Jonathan_Clarke

Jonathan_Clarke

    Second Unit

  • 485 posts
  • Join Date: Jul 22 2004

Posted October 19 2005 - 03:04 AM

I'm just having problems finding it. Posted Image
www.notinmybook.comWhere I can complain and complain and complain.

#10 of 51 PatWahlquist

PatWahlquist

    Supporting Actor

  • 735 posts
  • Join Date: Jun 13 2002

Posted October 19 2005 - 03:56 AM

I put it in my Bravo D-1 and it would freeze two seconds after the disc started. You'd hear the opening piano chords of the WB intro, then it actually crashed the D-1. I finally got it out of the machine, wiped off the disc and put it back in. It was fine then.
Anyone know where the layer switch is? I had about a 1 second pause about 3/4 of the way thru the movie. This is the biggest layer pause I've ever noticed on this player.
ISO "Lost" ARG prints from Kevin Tong, Olly Moss, Eric Tan and Methane Studios.  PM me if you want to sell!

All reviews done on a Marantz VP11S1 1080p DLP projector.

Displays professionally calibrated by Gregg Loewen of Lion AV.

#11 of 51 Kevin Lamb

Kevin Lamb

    Stunt Coordinator

  • 245 posts
  • Join Date: Aug 01 2004
  • Real Name:Kevin Lamb

Posted October 19 2005 - 04:03 AM

I'm just having problems finding it.

Interesting. I drove out to Best Buy to take advantage of a $10 BB gift card and the holographic cover on the Deluxe Edition (wicked cool!) and they only had *three* left in the store. I grabbed one and someone else grabbed another. So as we walked up to the checkout counter there was literally one Deluxe Edition left in the store. After less than a *day*. They had a ton of the single discs for $14.99 though.

Is it common for Best Buy to understock so dramatically or is the Deluxe selling out everywhere?

It played fine on my JVC btw.

#12 of 51 Lou Sytsma

Lou Sytsma

    Producer

  • 5,260 posts
  • Join Date: Nov 01 1998

Posted October 19 2005 - 04:06 AM

Worked fine on my LG and Panny RV32 but keep getting an audio drop out in midflight of the first Tumbler roofjump - layer change? - and a quick picture breakup when Bats enters the Cave with Rachael and gets out of the tumbler on my RP91. Weird as it is the best quality player of the three.

BTW the bass on this thing is insane!
Every man is my superior, in that I may learn from him.

#13 of 51 BennyD

BennyD

    Stunt Coordinator

  • 70 posts
  • Join Date: Jun 01 2004

Posted October 19 2005 - 04:56 AM

No problems on my Sony player. I'll update with the model number when I get home tonight.

#14 of 51 Porfirio

Porfirio

    Second Unit

  • 256 posts
  • Join Date: Jul 26 2000

Posted October 19 2005 - 05:01 AM

I Rented the single disc edition this weekend and did not have any playback problems on my Sony DVP-S550D.

#15 of 51 Jeremy Little

Jeremy Little

    Supporting Actor

  • 772 posts
  • Join Date: Jun 09 2001

Posted October 19 2005 - 05:41 AM

Quote:
Is it common for Best Buy to understock so dramatically or is the Deluxe selling out everywhere?


No, not on such a big title. Did you see the Batman Begins Shipper? Most of my store's stock came in on that big thing. It had full screen on one side and Widescreen on the other at the top and the bottom of both sides were filled with the 2-disc edition. We also got in several loose copies to fill our new release/feature wall and the inline area.
If it wasn't for my horse, I wouldn't have spent that year in college.

#16 of 51 Larry Sutliff

Larry Sutliff

    Screenwriter

  • 2,853 posts
  • Join Date: Jun 17 2000

Posted October 19 2005 - 06:10 AM

It played fine on the Oppo DV971H.

#17 of 51 Karl B

Karl B

    Extra

  • 15 posts
  • Join Date: Jan 16 2004

Posted October 19 2005 - 07:40 AM

Hi. Just thought I'd add that I'm having problems with the 2-disc Region 3 Batman Begins.

Playing it on my Pioneer 414 it gets to approx 76mins then breaks up for about minute/minute and half.

Bit annoying as the disc itself is spotless, and I've had five region 3 discs in the past that have all played fine (including a Warner film).

Oh, disc was made in Taiwan, if that makes any difference.

#18 of 51 Ivan Lindenfeld

Ivan Lindenfeld

    Second Unit

  • 336 posts
  • Join Date: Apr 23 2000

Posted October 19 2005 - 07:43 AM

Had horrible problems with Disc 2 of the DE on my Apex. Would load the first screen, but navigation would fail at various points in the comics, ending in a lockup. I tried various times.

I loaded it into my 1997 Toshiba player in the bedroom and watched some special features for about an hour until I fell asleep! Dammit! WHo needs sleep, this is Batman Begins!

I just junked my first Apex since it stopped recognizing any media, CD, DVD, commercial, burned, etc. Not bad, I thought, for 2 years and $35 spent.

After reading this thread I am not convinced it is my player, but I did experience an audio dropout with the "new" (in the box but 2 years old)Apex at the very beginning of "Cinderella". I have not yet tried that disc in my Tosh.

Bad discs are such an inconvenience.
Ivan Lindenfeld

#19 of 51 tonyKwok

tonyKwok

    Stunt Coordinator

  • 92 posts
  • Join Date: Mar 02 2005

Posted October 19 2005 - 08:55 AM

no problem on my phillips 647 DVD player.

#20 of 51 Ronald Epstein

Ronald Epstein

    Studio Mogul

  • 39,311 posts
  • Join Date: Jul 03 1997

Posted October 19 2005 - 09:47 AM

Just wanted to get back to you. Plays perfect
on my Panasonic RP91.

My God! I forgot how awesome a movie this is!

Ronald J Epstein
Home Theater Forum co-owner

 

gallery_269895_23_10043.jpg Click Here for the latest/hottest Blu-ray Preorders gallery_269895_23_1316.jpg Click Here for our complete Blu-ray review archive

gallery_269895_23_773.jpg Click Here for our complete 3D Blu-ray review archive gallery_269895_23_992.jpgClick Here for our complete DVD review archive

gallery_269895_23_7246.jpg Click Here for Blu-Ray Preorder Release Schedule gallery_269895_23_3120.jpg Click Here for forum posting rules and regulations