Jump to content



Sign up for a free account!

Signing up for an account is fast and free. As a member you can join in the conversation, enter contests to win things like this Logitech Harmony Ultimate Remote and you won't get the popup ads that guests get. Click here to create your free account.

Photo
- - - - -

How to play a DTS audio CD on my PC?


This topic has been archived. This means that you cannot reply to this topic.
7 replies to this topic

#1 of 8 Brett_H

Brett_H

    Second Unit

  • 345 posts
  • Join Date: Oct 03 2001

Posted January 28 2004 - 12:54 AM

So I picked up a copy of the Allman Brothers "Live at Fillmore East" DTS CD only to find that my DVD player doesn't support them. I decided to try playing it on my PC, but didn't have much luck. Windows Media Player fired up and started playing, but it was nothing but static. So my question is, what do I need to play this thing?

My system specs:
Asus A7V8X with onboard audio
Windows XP
Samsung combo CD-RW/DVD-rom drive

I have the SPD/IF output from the onboard sound hooked to my receiver (H/K 520), but for some reason didn't think to check if it was passing anything to it, I was only trying to listen on the PC using the analog output.

Thanks,
-Brett.

#2 of 8 Patrick Sun

Patrick Sun

    Studio Mogul

  • 37,617 posts
  • Join Date: Jun 30 1999

Posted January 28 2004 - 02:40 AM

You should try setting your HK to decode dts on the digital audio input used for the S/PDIF from the PC. You'll also have to figure out if the PC is outputting the CD's digital bitstream through the S/PDIF output.
"Jee-sus, it's like Iwo Jima out there" - Roger Sterling on "Mad Men"
Patcave | 2006 Films | 2007 Films | Flickr | Comic-Con 2012 | Dragon*Con 2012

#3 of 8 Christian Behrens

Christian Behrens

    Supporting Actor

  • 712 posts
  • Join Date: Mar 02 2000

Posted January 28 2004 - 04:03 AM

I was only able to play DTS CDs on my computer with WinDVD, but interestingly it sped up the music.

You should have no problems playing it with any stand-alone DVD or CD player that has a digital out. As Patrick said, check your settings.

-Christian
"They that can give up essential liberty to obtain a little temporary safety deserve neither liberty nor safety." (Benjamin Franklin)

#4 of 8 StephenL

StephenL

    Second Unit

  • 341 posts
  • Join Date: Nov 21 2000

Posted January 28 2004 - 04:07 AM

Some sound cards resample 44.1KHz audio to 48KHz, and Windows Kmixer performs sample rate conversion, preventing bit-perfect output. Any resampling will corrupt the bit stream, preventing DTS playback. To achieve bit-perfect output you need a sound card that doesn't resample, a driver that bypasses Windows Kmixer and a player that works with the soundcard and driver. I'm using a Hoontech Soundtrack Audio DSP24 Value soundcard with optional digital I/O bracket connected via TOSLINK SPDIF to an Onkyo TX-DS898 receiver, Windows Media Player 9 or J. River Media Jukebox, and Windows Media Audio Lossless compression. Make sure all volume controls are at maximum and there is no other digital processing (volume leveling, EQ, etc).

Did you try playing the DTS Audio CD though your DVD player's digital output with your receiver set to decode DTS?
"It's most disappointing. I shall have to go all-out on some modifications."

#5 of 8 Jesse Blacklow

Jesse Blacklow

    Screenwriter

  • 2,049 posts
  • Join Date: Oct 14 2002

Posted January 28 2004 - 04:37 AM

I think it has something to do with audio resampling and it's something only top-end consumer cards (like the M-Audio Revolution and Sound Blaster Audigy2 Platinum) can do with a little tweaking. This thread on the AVS Forum discusses it a little. I remember trying it with my DTS CDs, to no avail. If you have a Playstation 2, they play them just fine.
"Would I rather be feared or loved? Um...easy, both. I want people to be afraid of how much they love me."
--Michael Scott, The Office

"When I get sad I just stop being sad and be awesome instead. True story."
--Barney Stinson, How I Met Your Mother

#6 of 8 Brett_H

Brett_H

    Second Unit

  • 345 posts
  • Join Date: Oct 03 2001

Posted January 28 2004 - 05:12 AM

OK, a couple more details here: first, like a dope, I posted this from work where I can't try any of this out, so I won't know if anything works until tonight when I get home. (because I know you're all just dying to know the outcome!)

I did try playing this disc in my DVD player, but it gave an error to the effect that this was a non supported disc. It's a Panasonic F85K and it has no problem passing the DTS stream from DVD-V discs, it just didn't seem to like this DTS CD.

I'm beginning to think I might be stuck on this, just because I'm not using anything fancy for sound, just the onboard audio provided by the A7V8X motherboard, which is a VIA chipset.

I'll post more when I get home, if anyone's got further suggestions, feel free to post them up.

Thanks,
-Brett.

#7 of 8 Brett_H

Brett_H

    Second Unit

  • 345 posts
  • Join Date: Oct 03 2001

Posted January 28 2004 - 09:47 AM

HA!

From that other thread:
Quote:
For DTS CD audio the volume must be set to max so that bit perfect data is passed to the S/PDIF output.


It couldn't possibly be that simple, could it?

[maxes volume in WMP]

WOOHOO! It works!

OK, I actually did a few other things before this:
turned off all EQ settings in Windows Media Player
turned off SRS effects in WMP

Turns out any of these three things (volume not at 100%, SRS or EQ on) will cause the bitstream to get messed up!

At any rate, it's working now, time to go enjoy it.

Thanks,
-Brett.

#8 of 8 DaveDickey

DaveDickey

    Stunt Coordinator

  • 235 posts
  • Join Date: Aug 18 2003

Posted January 28 2004 - 10:40 AM

Brett,
I have the ABB "Fillmore" DTS disc too. I hate to break it to you, but it's the worst sounding DTS title I've heard (I have about 15 of them). The remastered CD sounds better - honestly. Don't be too upset if you can't get it to play properly.
Dave