-

Jump to content



Photo
- - - - -

What happened to my Pioneer Plasma (505HD)? All I get is a flashing green LED......


This topic has been archived. This means that you cannot reply to this topic.
3 replies to this topic

#1 of 4 OFFLINE   PouyaG

PouyaG

    Agent

  • 38 posts
  • Join Date: Feb 06 2001

Posted September 07 2003 - 01:51 PM

Hello,

As my title suggests I have a Pioneer PDP-505HD Plasma HDTV. We've had it for years and last night we watched a DVD then some TV, and went to bed. This morning I tried to turn on the TV and it makes the typical "snapping" noise a TV makes when it attemps to turn on, except I never get a picture. Ever. The LED on the bottom left which is supposed to be a solid green flashes every few seconds. And the set itself does not respond to any input via the remote or buttons on the set. I cannot fathom what happened Posted Image

Can anyone provide assistance? Thanks in advance

#2 of 4 OFFLINE   PouyaG

PouyaG

    Agent

  • 38 posts
  • Join Date: Feb 06 2001

Posted September 08 2003 - 04:37 PM

b0mp

#3 of 4 OFFLINE   John Royster

John Royster

    Screenwriter

  • 1,089 posts
  • Join Date: Oct 14 2001

Posted September 09 2003 - 01:21 AM

try resetting the TV by unplugging it for a few minutes.

You can also go to pioneer's web site and check the manual. Mine was a flashing red (meaning a malfunction).

#4 of 4 OFFLINE   PouyaG

PouyaG

    Agent

  • 38 posts
  • Join Date: Feb 06 2001

Posted September 07 2011 - 04:00 AM

Thanks. My then-girlfriend Josanna Shwee Sen Fah Smith Lewin (also known as Jawwwwzaaaan) prob broke it. Needless to say I dropped her like a bad habit of gurri gurri sauce.