Jump to content



Sign up for a free account to remove the pop-up ads

Signing up for an account is fast and free. As a member you can join in the conversation, enter contests and remove the pop-up ads that guests get. Click here to create your free account.


Photo

Static Sound from Paradigm Studio 60 V2 - Can anyone help?


  • You cannot start a new topic
  • Please log in to reply
6 replies to this topic

#1 of 7 OFFLINE   JohnKings

JohnKings

    Stunt Coordinator



  • 176 posts
  • Join Date: Dec 02 2001

Posted January 21 2003 - 10:30 AM

Approximately one year ago I purchased a pair of Paradigm Studio 60's in Canada. Just recently, I noticed that one of the speakers seems to have some type of staitic sound emanating from it (it is especially noticable on quieter acoustic passages). Over the next few hours, after following the troubleshooting directions of my local Paradigm dealership (i.e. swapping speakers, drivers, etc.), we have determined that it is not a faulty driver, but something else internal to the speaker. My local dealership will not service the speaker because it was purchased up north, so I do not know where to turn. Has anyone experienced this problem or have any idea what might be causing it? Also, if anyone has any idea who I could contact at paradigm for assistance that would also be helpful. I tried emailing their tech support, but have received no response. John

#2 of 7 OFFLINE   PomingF

PomingF

    Second Unit



  • 343 posts
  • Join Date: Mar 04 2000

Posted January 21 2003 - 12:41 PM

John, I suggest you hook up your speakers to a friend's functioning system to see if the problem persists for I had kinda the same problem intermittently till I finally decided to change interconnects within the path of the problem system. It so turned out one of them has a loosed solder and changing it out definitely took care of the problem. Good luck. PF

#3 of 7 OFFLINE   Chas_T

Chas_T

    Supporting Actor



  • 758 posts
  • Join Date: Jun 01 2002

Posted January 21 2003 - 01:41 PM

[quote] I tried emailing their tech support, but have received no response. [quote]

I don't know when you mailed Paradigm, but Gary Takeda answered my past mails and it took him 1-2 days to respond.

You might want to give them a call if you are not happy with the response time on the E-mail. Sorry about your problem.

Charles

#4 of 7 OFFLINE   Jason Brent

Jason Brent

    Second Unit



  • 268 posts
  • Join Date: Dec 12 2002

Posted January 21 2003 - 03:25 PM

I too have always gotten a response from Gary. You can also reach him at 905-632-0180. I think that's the right number. It's AudioStream's number which is all part of the same company.

I tried to get some more info on the Statement line, but he wouldn't give anyPosted Image

That said, have you tried to hook up another speaker to the same receiver/amplifier, using the same speaker wires and everything? If you don't get the noise, then you should be relatively certain that it's in the speaker. I would try to positively identify that the problem is in the speaker somewhere before trying to contact Gary.

If through the process of elimination you determine the problem is in the speaker, I would think that Gary could help you with the warranty repair.

#5 of 7 OFFLINE   Chas_T

Chas_T

    Supporting Actor



  • 758 posts
  • Join Date: Jun 01 2002

Posted January 21 2003 - 05:14 PM

Just to add something here, Gary was/is always very congenial and also very helpful. He once took a large amount of time out of his day to explain to me on the telephone the advantages of a speaker purchase I was making and his advise was right on the money.

#6 of 7 OFFLINE   altan

altan

    Stunt Coordinator



  • 81 posts
  • Join Date: Nov 19 2002

Posted January 22 2003 - 09:13 AM

From my converstaion with Paradigm/AudioStream I was surprised to find - Paradigm "the company" will not help with any repairs - All repairs must be done via Authorized Dealer - An authorized Paradigm dealer is not required to service your speakers if the purchase wasn't from the store you are attempting to get service from (even when they were purchased from an official Paraidgm dealer!) ... Altan

#7 of 7 OFFLINE   Chas_T

Chas_T

    Supporting Actor



  • 758 posts
  • Join Date: Jun 01 2002

Posted January 22 2003 - 09:31 AM

Altan, This is one of the issues that Paradigm displays with its stringent dealer attitude. Some find it negative and others postive. Fortunately, I've never had any issues with their speakers, so I've never been able to find this out by personal experience. The vast majority of my components have been purchased with the "home boy" attitude of doing business close to home. That trip to Canada always looks inviting and I've contemplated it myself quite a few times. However, if things go well and there aren't any problems, then it's worth the effort and the cost savings. There is always that risk of course as you have noted if the local dealer will not assist you in solving the problem.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users