1. Guest,
    If you need help getting to know Xenforo, please see our guide here. If you have feedback or questions, please post those here.
    Dismiss Notice

Yamaha RX-V596 blown channel? New replacement?

Discussion in 'AV Receivers' started by David Ugan, Dec 18, 2003.

  1. David Ugan

    David Ugan Member

    Joined:
    Dec 18, 2003
    Messages:
    14
    Likes Received:
    0
    hello all....this is my first post, mainly because i just encountered a problem last night. There is substantial snow/static noise coming from one of my rear surrounds, even when i do the test tone on the receiver. (it has become substantially worse over the last month - it started out barely noticeable).. you can also tell, even through the test tone, that the level of sound is not even close to the other rear. its not the speaker or wire because i plugged in a perfectly good speaker into the same port on the back of the receiver and it did the same thing. and the settings for each rear is the same...so,im guessing its either a blown channel (is there such a thing?) or maybe a bad connection on the speaker posts on the receiver? im also running only 16 gauge speaker wire about 30 feet but i dont think that could have such a disastrous affect....also, they are clip posts, not binging posts on the receiver. could it be dust? what about some random piece of speaker wire getting stuck in the receiver? im really stumped here and dont really want to buy another receiver.

    if a channel is blown, is there any makeshift way i could still get quality sound out of my rear channels? and finally, if i do have to get a new receiver, i was thinking about the onkyo 501.....at $300, it looks like a steal and its gotten great reviews here and other places...will it handle playing very loud for long intervals (3-5 hours) is my question though...

    heres my sound setup too:

    klipsch kg 4.2s up front
    klipsch kv3 center
    jbl subwoofer
    yamaha rx-v596 receiver
    two cheapie klh speakers for my rears (waiting for next years tax return!)....i know these suck, but they cant be responsible for a blown channel can they???
     
  2. RobCar

    RobCar Well-Known Member

    Joined:
    Nov 27, 2002
    Messages:
    201
    Likes Received:
    0
    Hmm. I'd see if you can someone look at it. Might be a quick fix, like perhaps there's a static problem or something simple. Or as you suggest, maybe something with the connectors. Look in the phone book and try to find an independent guy that works on audio equipment -- he'd be able to give you a diagnosis w/in minutes, and for not much.
     

Share This Page