1. Guest,
    If you need help getting to know Xenforo, please see our guide here. If you have feedback or questions, please post those here.
    Dismiss Notice

Weird Hum from Velodyne sub. HELP

Discussion in 'Home Theater Projects' started by Greg Risley, Dec 23, 2004.

  1. Greg Risley

    Greg Risley Second Unit

    Joined:
    Sep 21, 1998
    Messages:
    289
    Likes Received:
    0
    Before someone says its a ground loop, let me say that it is a different kind of hum, and that I have had another sub hooked to the same outlet before with no hum.
    Heres the story. The sub in question is a Velodyne F1800RII. I have traded subs with my father since his theater is not ready in the new house. The sub was in storage for 6 months before being moved to the new house. Well when I get it home and plug it in to the same outlet as my previous sub, and turn it on, after a few seconds it starts to hum and slowly grow in volume to where it sounds like some damage may about to happen so then I turn it of and get a loud thumping pop. This happens wether it is hooked up to the pre-amp or free standing. The volume is also all the way down. I have pulled the plate amp and driver off and found no loose connections.

    Any ideas what it might be? I would like to avoid boxing and shipping the thing off to Velodyne.

    Thanks
    Greg
     
  2. ThomasW

    ThomasW Screenwriter

    Joined:
    Nov 6, 1999
    Messages:
    2,282
    Likes Received:
    0
    Sounds like something in the amp has gone south.
     

Share This Page