1. Guest,
    If you need help getting to know Xenforo, please see our guide here. If you have feedback or questions, please post those here.
    Dismiss Notice

teac d200/pioneer s-hs100 issue and what to change it for

Discussion in 'Beginners, General Questions' started by spooner007, May 15, 2013.

  1. spooner007

    spooner007 New User

    Joined:
    May 15, 2013
    Messages:
    2
    Likes Received:
    0
    Real Name:
    craig
    Hi
    I bought a teac d200 AVR and pioneer s-hs100 speakers. I have an issue where after approx. 1.5 hrs of something like avengers movie I get a click from the receiver and a major loss in sound (most noticeably bass). Volume levels have been set at no more than half level on the receiver during this time but bass is set a little higher in setup (about 8db)

    Richer sounds have given me the kit on a 14 day trial and have agreed to swap out the amp for a sony strdh820.

    This is where I get a headache.. I have noticed the ohm rating on the sony is 8-16 and the rating on the speakers is 6ohm. I have also read that a combination such as this can cause the amp to overheat and possibly a drop in sound levels whilst it cools down. Is this what I am already getting with the teac rated 6ohm?. If so if I get the sony will my problem still exist?.

    Do I go for the sony or something simpler like a Yamaha yht-298 @£229 or a Yamaha yht-398 @299. Which will give the best sound and value for money out of the 3 setups I have suggested?

    Or if anyone has a suggestion for a setup up to £300 from richer sounds I would be gratefull.

    Thanks in advance for any advice given
     

Share This Page