1. Guest,
    If you need help getting to know Xenforo, please see our guide here. If you have feedback or questions, please post those here.
    Dismiss Notice

Sony STR-DE845 Reciever making clicking noises

Discussion in 'AV Receivers' started by MikeCin, Nov 16, 2005.

  1. MikeCin

    MikeCin Member

    Joined:
    Dec 4, 2003
    Messages:
    22
    Likes Received:
    0
    Real Name:
    Michael
    I had this reciever for a long time, And it's been making these clicking noises a lot lately, Last night I was watching a DVD and I heard those clicking noises when I noticed that the rear channel speakers weren't working, Even durring the test tone. But when it clicks again, The rear channel speakers starts working again, The speaker wires are all fine, They are all connected properly and such, Any idea on whats causing the reciever to click like that?
     
  2. John Garcia

    John Garcia Well-Known Member

    Joined:
    Jun 24, 1999
    Messages:
    11,572
    Likes Received:
    23
    Location:
    NorCal
    Real Name:
    John
    This seems to be a fairly common issue with older Sony receivers. I've seen this question asked quite a bit lately, so it must have something to do with their design. IMO, these are not the best built receivers out there, so it doesn't surprise me (I used to own a 815). I'd seriously recommend a new receiver and maybe you can throw that one in another room or use it to power another zone in the house.
     
  3. MikeCin

    MikeCin Member

    Joined:
    Dec 4, 2003
    Messages:
    22
    Likes Received:
    0
    Real Name:
    Michael
    But any idea on whats causing the clicks and how to prevent it from happening again?, I don't really have enough money to go out and buy a new reciver, However, I have an older receiver which is from Technics, But it's dolby digital ready and recovers those 5.1 connections onto it, But my DVD Players dont have 5.1 outputs for it, If theres a solution to the problem with these Sony recievers, I would like to know. Since you mention this is a common problem with these recivers, Surely there has to be some sort of fix for them?
     
  4. John Garcia

    John Garcia Well-Known Member

    Joined:
    Jun 24, 1999
    Messages:
    11,572
    Likes Received:
    23
    Location:
    NorCal
    Real Name:
    John
    I think it is a relay going bad or a short on the main board (which may affect the relays), that's why you hear the clicks. I couldn't tell you if there's a fix, but if there is, it most likely involves you sending it out for repairs. You can certainly find a DVD player with 5.1 output cheaper than you will find a new receiver. By common, I mean I've seen this same question about 4 or 5 times in the last month or so regarding older Sonys on this and other forums.
     
  5. MikeCin

    MikeCin Member

    Joined:
    Dec 4, 2003
    Messages:
    22
    Likes Received:
    0
    Real Name:
    Michael
    Even though you could just buy a DVD Player with the 5.1 outputs, The only problem with those is that they don't suport DTS on the 5.1 outputs themself, Only Dolby Digital 5.1.
     
  6. MikeCin

    MikeCin Member

    Joined:
    Dec 4, 2003
    Messages:
    22
    Likes Received:
    0
    Real Name:
    Michael
    Oh another problem I forgot to mention, It seems from time to time, The volume knob won't move when I tried to raise the volume or lower it with the sony remote, I have to turn the knob from side to side sometimes in order to get the knob's motor to work again.
     
  7. Jeff Pounds

    Jeff Pounds Well-Known Member

    Joined:
    Jun 6, 2000
    Messages:
    386
    Likes Received:
    0
    Mike --
    I feel your pain!
    I actually have an active thread talking about this same problem here. (Although it is the center channel that drops out on me... not the surrounds)
    Intersting that you have the DE845... I have the DB840.
    Most responses on the Forums have been suggesting that I have a speaker or wire problem.
    Also, I wouldn't expect to get anywhere with Sony. I had a local authorized Sony repair shop check it out a few months ago only to find "no problem." After getting my receiver back, the problem was still there.
    I broke down and sent my receiver into Sony about a month ago, and after calling customer service every business day for the past week or so, they have finally told me that they can "find no problem" and that I should "check my speakers and wires."
    I suspect that, given others have had the same problem with these receivers, that it is some sort of physical problem with the receiver that isn't on their radar and is hard to detect.
    It's a MADDENING problem to say the least, due to the intermittant nature of the problem... [​IMG] [​IMG] [​IMG]
    This, needless to say, will be my LAST Sony product, ever.
    All of that said, keep me updated on your progress.
    One thing you might try is your local authorized Sony repair shop (if you have one in your neck of the woods). If your guy can figure out a fix, I would be willing to ship my receiver to him for the fix! (If I ever get it back from Sony, that is...)
     
  8. MikeCin

    MikeCin Member

    Joined:
    Dec 4, 2003
    Messages:
    22
    Likes Received:
    0
    Real Name:
    Michael
    Well, The thing is, I don't really have any money to send it out to repair, And right now It hasnt clicked today, Anyways, What about the problem with the motor that operates the knob when using the remote, Has there been any problems with it not working when using the remote, Cause in order to get it to work at times, I have to turn the knob from side to side in order for the motor to start working again so I can use the volume on the remote.
     
  9. PatrickJB

    PatrickJB Member

    Joined:
    Oct 26, 2005
    Messages:
    19
    Likes Received:
    0
    "You can certainly find a DVD player with 5.1 output cheaper than you will find a new receiver."
    My Sony is doing the exact same thing and it affects the center and rears. Using the 5.1 out from a DVD will not correct this issue as the sound will still not be produced from the bad chanels.
    I spent 1/2 hour one night listening for where the clicking comes from and it is right inside of the case behind the center and rear speaker connections. I opened the case and found 4 blue small boxes which I assume are the relays mentioned above. I didn't try too hard but it seems like these are perminately affixed and not DIY friendly, although I am no electrician...just my uneducated opinion.
    My 'homebrew' remedy for a while was to tap on the back of the case with my finger near the speaker connections. this enabled all the speakers for a while but the issues came back once again. This, of course, is not a perminent fix [​IMG] Oddly enough, if I tapped around where the A B selector is on the front of the case the sound would come back for a short time as well. You can also try the fist/pound method as opposed to the tapping but at your own risk.
    Anyone have diagrams or mechanical manuals for these recievers?
    I do plan on getting a new reciever soon but would like to fix this one instead of chucking it.
     
  10. Jeff Pounds

    Jeff Pounds Well-Known Member

    Joined:
    Jun 6, 2000
    Messages:
    386
    Likes Received:
    0
    Patrick,

    Interesting...

    Can you see where the relays are soldered to the board?

    One of the theories one of my HT friends had about this problem was that there was bad solder connections on the board somewhere causing the problem.

    This would explain why my problem would happen at first, but then go away after the unit had heated up.

    The crazy thing is that the problem seemly can't be replicated in the shop. I had a local authorized Sony guy look at mine AND I sent the unit to Sony and neither place could replicate the problem!

    That's why I'm thinking that there IS a problem with the unit, but it could be that it's just MORE sensitive to wiring issues.

    Thus, when I get my unit back (supposedly in the next day or so), I'm replacing all of my wiring to my mains and will see if that remedies the problem.

    Although I wasn't ready to upgrade my receiver just yet, I will say that it is DEFINITLY next on the list, and Sony is totally eliminated from the list!
     
  11. MikeCin

    MikeCin Member

    Joined:
    Dec 4, 2003
    Messages:
    22
    Likes Received:
    0
    Real Name:
    Michael
    Last night it wasn't clicking, But the clickings are back, Everytime it happens, I either loose the real channel or get it back, I checked the speaker wires and non of the wires are touching one another, They all seem find, I don't know why it still does this.
     
  12. MikeCin

    MikeCin Member

    Joined:
    Dec 4, 2003
    Messages:
    22
    Likes Received:
    0
    Real Name:
    Michael
    Heres an update, I just unplugged all the speaker wires, Reset the receiver and plugged all the wires back and such, And the clicks are still happening.
     
  13. John S

    John S Well-Known Member

    Joined:
    Nov 4, 2003
    Messages:
    5,460
    Likes Received:
    0
    Take the AVR back to two channel, and see if it still does it. This will eliiminate much that could cause it.
     
  14. MikeCin

    MikeCin Member

    Joined:
    Dec 4, 2003
    Messages:
    22
    Likes Received:
    0
    Real Name:
    Michael
    Well, the clicking still continues, the only way I can get the rear channels to work is to tap the top right of the receiver then it would click and the rear channels come back, Most of the time it would come back and then go away, Forcing me to continue tapping it til it returns, This is becoming annoying, is there anything in there that might be loose thats causing this?
     
  15. John S

    John S Well-Known Member

    Joined:
    Nov 4, 2003
    Messages:
    5,460
    Likes Received:
    0
    yes, pull the board, re-solder any suspect looking solder joints. best of luck with it.
     
  16. Steve Berger

    Steve Berger Well-Known Member

    Joined:
    Sep 8, 2001
    Messages:
    970
    Likes Received:
    2
    There could be a few things causing this. First (with the unit unplugged) take a screwdriver and loosen then tighten all the screws holding the circuit boards down. The ground return circuit is through these mounting points and they work loose over time.

    Other problems can be the relays themselves coming unsoldered. This is a common problem among all manufacturers as the receivers age. You might be able to get at them by removing the lower shield without removing the circuit board.

    Another problem seen has been on the front panel where the 2 or three circuit boards connect to each other with some connectors. These can also have solder connections break down. This alters the data going to the digital processing board causing it to change decode modes.

    On the digital board the three pin regulator IC's can also develop bad solder connections. Caution should be exercised if you attempt to work on this board.

    Extreme caution needs to be taken around the power supply filters. The stored charge can weld a screwdriver to the case.
     
  17. MikeCin

    MikeCin Member

    Joined:
    Dec 4, 2003
    Messages:
    22
    Likes Received:
    0
    Real Name:
    Michael
    Hmm, I don't know a thing about soldering though, Seems like something very complicated and that only a technician can do this kind of stuff.
     
  18. Kean-Hock Yeap

    Kean-Hock Yeap Well-Known Member

    Joined:
    Oct 5, 2004
    Messages:
    82
    Likes Received:
    0
    Mike, it's probably time to bite the bullet and replace your receiver. I know your budget is very limited, so maybe go for a used one? Either that or just forget about the rear channels and live with the 3.1 setup using your current receiver.
     
  19. Steve Berger

    Steve Berger Well-Known Member

    Joined:
    Sep 8, 2001
    Messages:
    970
    Likes Received:
    2
    With no technical ability, I would only suggest tightening the ground screws that hold the boards down to the frame.

    The 845 is not too hard to work on since it has an access panel on the bottom. If you can find a smaller service company, this is a fairly simple repair. It might make more sense to spend $35 - $45 on repairing this unit than $200+ on a replacement. I have an 835 that works fine in my home theater environment.
     
  20. Jeff Pounds

    Jeff Pounds Well-Known Member

    Joined:
    Jun 6, 2000
    Messages:
    386
    Likes Received:
    0
    Mike...

    Have you checked and re-checked ALL of the places where you have speaker wires terminating?... i.e. wall plates, speaker terminals, receiver terminals...

    The reason I ask is becuase I finally figured out that my problem was a TINY bit of the negative wire touching the positive terminal of one of my surrounds on the in-wall side of my wall plate behind my receiver.

    Since I corrected that, the clicking and "protect" mode problem have gone away.

    I'm not sure what kind of connectors you have (bananna, clip, pin, bare wire, etc.), but if you check everything and there seems to be no problem, you may even try re-stripping all of your wire ends where you have connections.

    It is possible that you have some oxidation/corrosion of the exposed copper that is causing the problem. It may not seem like much, but it just seems to me that these 3-4 year old Sony receivers are VERY sensitive to any sort of wiring problem/issue.

    Good luck!
     

Share This Page