1. Guest,
    If you need help getting to know Xenforo, please see our guide here. If you have feedback or questions, please post those here.
    Dismiss Notice

service mode on samsung sir-t165

Discussion in 'Playback Devices' started by Jim.Bennett, Apr 28, 2003.

  1. Jim.Bennett

    Jim.Bennett Member

    Joined:
    Dec 14, 2002
    Messages:
    22
    Likes Received:
    0
    Anyone figured out if there is a service mode on the 165 and how to get into it? Ive been playing around with a serial cable connected to the rs232 db9 connector on the back, attached to my COM1 serial connecter on my PC. So far all I have got back is "ssrs" every time I hit , this is using 7, Even, 1, no flow control as the parameters.
     
  2. Ron Economos

    Ron Economos Member

    Joined:
    Jan 25, 2003
    Messages:
    11
    Likes Received:
    0
    Try 57600,8,none,1,no flow control. I can change
    channels by typeing u (up) and d (down). Haven't
    got a menu yet.

    Ron
     
  3. Ron Economos

    Ron Economos Member

    Joined:
    Jan 25, 2003
    Messages:
    11
    Likes Received:
    0
    a = change aspect ratio

    d = channel down

    e = program guide

    f = display channel number

    i = display info

    k = debug menu (whoa!)

    m = menu

    p = channel change (but just DTV sub-channel)

    q = select SAP

    s = select Closed Caption service

    v = select video input

    Ron
     
  4. Jim.Bennett

    Jim.Bennett Member

    Joined:
    Dec 14, 2002
    Messages:
    22
    Likes Received:
    0
    Ron,

    Nice work! It didn't even occur to me to try talking to it while I had to connected to the TV still. I hauled it over to my PC and watched for responses in my terminal program. Interesting that you got responses using different parameters than I used. In my terminal program, I didn't get anything back using 8 Bits. I tried 9600, 7, Even, 1, no flow control and was getting "ssrs" when I hit enter. I was hoping for something simple, like as soon as I hit enter in my terminal program I would get a menu "****SAMSUNG SIR-T165****" but as you have found no such luck! But you have discovered a lot! I am playing with this program called comDebug, hoping that I would be able to glean so more info from the box without knowing what to actually send to it first. No luck with that yet. Let me know if you find out more, you have motivated me to keep plugging away and build on what you have so far.

    jim
     
  5. Patrick Sun

    Patrick Sun Moderator
    Moderator

    Joined:
    Jun 30, 1999
    Messages:
    38,552
    Likes Received:
    377
    So, what are we trying to change in the service mode of the T165? I'm very curious (also an owner of a T-165).

    Anyway we can get the unit to output black sidebars by mucking around in the service mode? [​IMG]

    Or how about getting the black levels to look correct when upconverting video from the composite/s-video inputs.
     
  6. Jim.Bennett

    Jim.Bennett Member

    Joined:
    Dec 14, 2002
    Messages:
    22
    Likes Received:
    0
    Here is what the boot sequence looks like:


    0103



    SAMSUNG PRL3100 Boot ROM for TL810B + QED CPU Card
    (QED.CLK=2X,QED.DRV=83%)

    04 Initialize SDRAM ...05 06 07 Initialize primary caches ...OK
    08 09 12 13 Copying , Please wait for a seconds
    14 15 16 17 18 19 20 51 22 CACH
    ZERO
    TYPE
    COPR
    CNFG
    FLSH
    EXCP
    SIZE
    STAK
    INIT
    23 AInitBoard()
    BCpciInit(): Entered
    >
    >
    sysPci.c : intLock()
    pci0: Probing for device (id select = A11) ...
    pci0: device (id select = A11) done pciConfigRegWrite32.
    pci0: device (id select = A11) exists.
    sysPci.c : scan completed
    pci0: device present (id select = A11) signature = 0x032b544c
    Reset PCI device 11
    Reset PCI device OK ?
    Vendor ID = 0x544c ("TERALOGIC INC.")
    Device ID = 0x032b ("TL810 REV B")
    Command = 0x0004
    Status = 0x0280
    Revision ID = 0x02
    Class Code = 0x00 ("PRE-PCI2.0")
    SubClass Code = 0x0000 ("NON-VGA DEVICE")
    Cache Line Size = 0x00
    Latency Timer = 0x00
    Header Type = 0x00 (single-function) Normal
    BIST = 0x00
    Base Address 0 = 0x00000000 (prefetchable memory region anywhere in 32-bit space)
    Size = 0x08000000 (128M bytes)
    Base Address 2 = 0x00000000 (I/O region)
    Error: Non-zero PCI base register with no configurable address bits!
    Size = 0x00000100 (256 bytes)
    Base Address 3 = 0x00000000 (memory region anywhere in 32-bit space)
    Size = 0x00100000 (1M bytes)
    Base Address 4 = 0x00000000 (memory region anywhere in 32-bit space)
    Size = 0x08000000 (128M bytes)
    Base Address 5 = 0x00000000 (memory region anywhere in 32-bit space)
    Size = 0x00001000 (4K bytes)
    CardBus CIS Ptr = 0x00000000
    ROM Base Addr = 0x00000000
    Interrupt Line = 0x00
    Interrupt Pin = 0x00
    Maximum Grant = 0x00
    Maximum Latency = 0x00

    pci1: Probing for device (id select = A12) ...
    pci1: device (id select = A12) done pciConfigRegWrite32.
    pci1: device (id select = A12) does not exist.
    Waiting for Abort to clear.
    pci1: device (id select = A12) Abort cleared.
    sysPci.c : scan completed
    pci1: no device

    pci19: Probing for device (id select = A30) ...
    pci19: device (id select = A30) done pciConfigRegWrite32.
    pci19: device (id select = A30) does not exist.
    Waiting for Abort to clear.
    pci19: device (id select = A30) Abort cleared.
    sysPci.c : scan completed
    pci19: no device

    pci20: Probing for device (id select = A31) ...
    pci20: device (id select = A31) done pciConfigRegWrite32.
    pci20: device (id select = A31) exists.
    sysPci.c : scan completed
    pci20: device present (id select = A31) signature = 0x0350544c
    Reset PCI device 31
    Reset PCI device OK ?
    Vendor ID = 0x544c ("TERALOGIC INC.")
    Device ID = 0x0350 ("TL850 REV B/C")
    Command = 0x0000
    Status = 0x0230
    Revision ID = 0x20
    Class Code = 0x04 ("MULTIMEDIA DEVICE")
    SubClass Code = 0x8000 ("MISC MULTIMEDIA DEVICE")
    Cache Line Size = 0x00
    Latency Timer = 0x00
    Header Type = 0x00 (single-function) Normal
    BIST = 0x00
    Base Address 0 = 0x00000000 (memory region anywhere in 32-bit space)
    Size = 0x04000000 (64M bytes)
    Base Address 3 = 0x00000000 (memory region anywhere in 32-bit space)
    Size = 0x00100000 (1M bytes)
    Base Address 4 = 0x00000000 (memory region anywhere in 32-bit space)
    Size = 0x00010000 (64K bytes)
    CardBus CIS Ptr = 0x00000000
    ROM Base Addr = 0x00000000
    Interrupt Line = 0x00
    Interrupt Pin = 0x01
    Maximum Grant = 0x04
    Maximum Latency = 0x04

    pciInit(): PCI pciDeviceAperturesAllocate
    Allocating device at IDSEL=A11 signature=0x032b544c
    Base address register 0 = 0x80000000
    Base address register 3 = 0x00000000
    Base address register 4 = 0x00000000
    Base address register 5 = 0x00000000
    Allocating device at IDSEL=A31 signature=0x0350544c
    Base address register 0 = 0x08000000
    Base address register 3 = 0x0c000000
    Base address register 4 = 0x0c100000
    DDEInstallSerialDriver = 0
    Set TL810Isr
    TL810 Interrupt Disable Bit Masked 0
    TL810 Interrupt Disable Bit Masked 0
    TL810 Interrupt Disable Bit Masked 0
    TL810 Interrupt Disable Bit Masked 0
    TL810 Interrupt Disable Bit Masked 0
    FpSOS

    [StorageRead] start=0x00000000, length=0x00000054, buff=0x800bc8a0
    PC16X50Init
    PC16X50Open
    pc16x50_reconfig
    Set_baud
    chan->port_base = 30400
    Set_baud
    findCs8900
    Lan Address Read 0
    read data is A040
    SSS = A040 BA040308
    Signature Error A040



    pSOSystem V2.5.0
    Copyright (c) 1991 - 1999, Integrated Systems, Inc.
    --------------------------------------------------------------------------
    START-UP MODE:
    Run the hello Application
    NETWORK INTERFACE PARAMETERS:
    IP address on LAN is 100.100.100.2
    IP address on SERVER is 100.100.100.1
    LAN interface's subnet mask is 0xffffff00
    HARDWARE PARAMETERS:
    Serial channels will use a baud rate of 38400
    This board's Ethernet hardware address is AA:BB:CC[​IMG]D:EE:F0
    After board is reset, start-up code will wait 0 seconds
    --------------------------------------------------------------------------
    To change any of this, press any key within 0 seconds
    PC16X50Init
    PC16X50lose
    PC16X50Open
    pc16x50_reconfig
    Set_baud
    chan->port_base = 30400
    Set_baud
    MAC address:aa:bb:cc:dd:ee[​IMG]0
    findCs8900
    Lan Address Read 0
    read data is A040
    SSS = A040 BA040308
    Signature Error A040
    PC16X50Open
    pc16x50_reconfig
    Set_baud
    chan->port_base = 30400
    Set_baud
    findCs8900
    Lan Address Read 0
    read data is A040
    SSS = A040 BA040308
    Signature Error A040
    ¬

    [ROOT] ....SIR_T165 Boot(pSOS Kernel V0.30) Ver S_TIROS73_006_F



    [BootROM] I2C bus is ok !!

    0103



    SAMSUNG PRL3100 Boot ROM for TL810B + QED CPU Card
    (QED.CLK=2X,QED.DRV=83%)

    04 07 Initialize primary caches ...OK
    08 09 12 13 Copying , Please wait for a seconds
    14 15 Skip Temp Copy
    17 18 19 21 SkipCached
    22 CACH
    ZERO
    TYPE
    COPR
    CNFG
    FLSH
    EXCP
    SIZE
    STAK
    INIT
    23 AInitBoard()
    BCpciInit(): Entered
    >
    >
    sysPci.c : intLock()
    pci0: Probing for device (id select = A11) ...
    pci0: device (id select = A11) done pciConfigRegWrite32.
    pci0: device (id select = A11) exists.
    sysPci.c : scan completed
    pci0: device present (id select = A11) signature = 0x032b544c
    Reset PCI device 11
    Reset PCI device OK ?
    Vendor ID = 0x544c ("TERALOGIC INC.")
    Device ID = 0x032b ("TL810 REV B")
    Command = 0x0004
    Status = 0x0280
    Revision ID = 0x02
    Class Code = 0x00 ("PRE-PCI2.0")
    SubClass Code = 0x0000 ("NON-VGA DEVICE")
    Cache Line Size = 0x00
    Latency Timer = 0x00
    Header Type = 0x00 (single-function) Normal
    BIST = 0x00
    Base Address 0 = 0x00000000 (prefetchable memory region anywhere in 32-bit space)
    Size = 0x08000000 (128M bytes)
    Base Address 2 = 0x00000000 (I/O region)
    Error: Non-zero PCI base register with no configurable address bits!
    Size = 0x00000100 (256 bytes)
    Base Address 3 = 0x00000000 (memory region anywhere in 32-bit space)
    Size = 0x00100000 (1M bytes)
    Base Address 4 = 0x00000000 (memory region anywhere in 32-bit space)
    Size = 0x08000000 (128M bytes)
    Base Address 5 = 0x00000000 (memory region anywhere in 32-bit space)
    Size = 0x00001000 (4K bytes)
    CardBus CIS Ptr = 0x00000000
    ROM Base Addr = 0x00000000
    Interrupt Line = 0x00
    Interrupt Pin = 0x00
    Maximum Grant = 0x00
    Maximum Latency = 0x00

    pci1: Probing for device (id select = A12) ...
    pci1: device (id select = A12) done pciConfigRegWrite32.
    pci1: device (id select = A12) does not exist.
    Waiting for Abort to clear.
    pci1: device (id select = A12) Abort cleared.
    sysPci.c : scan completed
    pci1: no device

    pci19: Probing for device (id select = A30) ...
    pci19: device (id select = A30) done pciConfigRegWrite32.
    pci19: device (id select = A30) does not exist.
    Waiting for Abort to clear.
    pci19: device (id select = A30) Abort cleared.
    sysPci.c : scan completed
    pci19: no device

    pci20: Probing for device (id select = A31) ...
    pci20: device (id select = A31) done pciConfigRegWrite32.
    pci20: device (id select = A31) exists.
    sysPci.c : scan completed
    pci20: device present (id select = A31) signature = 0x0350544c
    Reset PCI device 31
    Reset PCI device OK ?
    Vendor ID = 0x544c ("TERALOGIC INC.")
    Device ID = 0x0350 ("TL850 REV B/C")
    Command = 0x0157
    Status = 0x0230
    Revision ID = 0x20
    Class Code = 0x04 ("MULTIMEDIA DEVICE")
    SubClass Code = 0x8000 ("MISC MULTIMEDIA DEVICE")
    Cache Line Size = 0x00
    Latency Timer = 0x00
    Header Type = 0x00 (single-function) Normal
    BIST = 0x00
    Base Address 0 = 0x08000000 (memory region anywhere in 32-bit space)
    Size = 0x04000000 (64M bytes)
    Base Address 3 = 0x0c000000 (memory region anywhere in 32-bit space)
    Size = 0x00100000 (1M bytes)
    Base Address 4 = 0x0c100000 (memory region anywhere in 32-bit space)
    Size = 0x00010000 (64K bytes)
    CardBus CIS Ptr = 0x00000000
    ROM Base Addr = 0x00000000
    Interrupt Line = 0x00
    Interrupt Pin = 0x01
    Maximum Grant = 0x04
    Maximum Latency = 0x04

    pciInit(): PCI pciDeviceAperturesAllocate
    Allocating device at IDSEL=A11 signature=0x032b544c
    Base address register 0 = 0x80000000
    Base address register 3 = 0x00000000
    Base address register 4 = 0x00000000
    Base address register 5 = 0x00000000
    Allocating device at IDSEL=A31 signature=0x0350544c
    Base address register 0 = 0x08000000
    Base address register 3 = 0x0c000000
    Base address register 4 = 0x0c100000
    DDEInstallSerialDriver = 0
    Set TL810Isr
    TL810 Interrupt Disable Bit Masked 4
    TL810 Interrupt Disable Bit Masked 4
    TL810 Interrupt Disable Bit Masked 4
    TL810 Interrupt Disable Bit Masked 4
    TL810 Interrupt Disable Bit Masked 0
    FpSOS

    [StorageRead] start=0x00000000, length=0x00000054, buff=0x809790b8
    PC16X50Init
    PC16X50Open
    pc16x50_reconfig
    Set_baud
    chan->port_base = 30400
    Set_baud
    PC16X50Init
    PC16X50lose
    PC16X50Open
    pc16x50_reconfig
    Set_baud
    chan->port_base = 30400
    Set_baud
    MAC address:aa:bb:cc:dd:ee[​IMG]0
    findCs8900
    Lan Address Read 0
    read data is A040
    SSS = A040 BA040308
    Signature Error A040
    PC16X50Open
    pc16x50_reconfig
    Set_baud
    chan->port_base = 30400
    Set_baud


    [ROOT 0.00] .... S_TIROS3_ S/W V1.01

    [ROOT 0.00] Print Task Creation Success
    [ROOT 0.01] Print Task Starting Success
    [ROOT 0.02] Uart Input Task Creation Success
    [ROOT 0.03] Uart Input Task Starting Success
    [ROOT 0.03] enter mounting TFS
    [ROOT 0.05] done mounted TFS 0
    [ROOT 0.05] tfs_fs_check 0
    TL810 Interrupt Disable Bit Masked 4
    TL810 Interrupt Disable Bit Masked 4
    TL810 Interrupt Disable Bit Masked 4
    TL810 Interrupt Disable Bit Masked 4
    [ROOT 0.03] 260 MSG buffers for 4 queues
    [ROOT 0.10] Cougar_Init OK !
    [ROOT 0.03] 8 Semaphores
    BANK[ROOT 0.11] Gpio initialization
    [ROOT 0.11] TL850 GPIO I2C initialization
    [ROOT 0.12] TL811 MASTER I2C initialization
    _BASE(fdev) = 0xbf3c0000
    flash_open: locatecntr = 0
    ftl_open() : NumEraseUnit FFFF
    ftl_open() : N[ROOT 0.15] Audio Chips HW reset
    [ROOT] VFD Initialization is successful
    [ROOT 0.16] Sending System Rdy to Submicom
    umEraseUnit 0002
    First valid EUN = 1 (euh.LogicalEUN = 0x0)
    check /
    AIR1CH
    AIR2CH
    CBL1CH
    CBL2CH
    dir&file check = 0
    FAT check : [ErrPrint] Now Set SYS 40960 MIF 1079705600
    [ErrPrint] SetMIFMacState MIFClockRate 1029 SysClockRate 1079705600
    Set[ROOT 0.22] Nvram Reading start
    ting Offset 1 Delay 2
    Setting Offset 1 Delay 2
    [API_VFD] Print Message : HELLO, Print Default Type : 1, Print Time Type : 1
    [cougar] size= 14a000
    [bsp] x=0, y=0, w=704, h=480, pitch=704, fmt=0, psize=32, baseaddr= a9dd1000
    [OK_SAA7128] addr = 0, data = 0, result= 0
     
  7. Jim.Bennett

    Jim.Bennett Member

    Joined:
    Dec 14, 2002
    Messages:
    22
    Likes Received:
    0
    There is also a method for adjusting for the DVI shift in the debug menu:

    [ DEBUG Main Menu. ]
    ---------------------------
    0x10: System Debug menu
    0x20: NTSC Debug menu
    0x30: DTV Debug menu
    0x35: 1394& IOEXP Debug menu
    0x36: DVI_SiI168 Debug menu
    0x40: DVR Engine Debug menu
    0x70: DVR Debug menu
    0x80: Key Secret Debug menu
    0x92: Micom Debug menu
    0x93: Led Send Stop
    0x94: Led Send Restart
    0x95: Key polling Stop
    0x96: Key polling Restart
    0x97: Get Frame Rate
    0x98: Print Seting status
    0x99: Print Seting menu
    ---------------------------
    0xff: EXIT from Main DEBUG Menu!!!.

    After hitting 0x36 here are the options:


    [ DEBUG DVI Menu. ]
    ---------------------------
    0x11: Init DVI transmitter
    0x12: De_DLY adjust
    0x13: De_TOp adust menu
    0x14: De_CNT adust menu
    0x15: De_LIN adust menu
    0x16: Reset_Hardware menu
    0x17: Drv_tryAuthentifi menu
    0x20: DVI debug set menu
    ---------------------------
    0xff: EXIT from DVI DEBUG Menu!!!.
     
  8. SeanA

    SeanA Well-Known Member

    Joined:
    Feb 16, 2003
    Messages:
    329
    Likes Received:
    0
    Hey... you fellas sound like you know what you are doing, and I hope you don't mind if I ask a mostly unrelated question. I have the Samsung SIR-T151 receiver and I have a problem. I connected the optical audio output of the SIR-T151 to my home theater receiver and so far I have not been able to get any sound out of it. I have tried it during the recent broadcast of movies such as Forrest Gump in hopes of pulling in surround sound... but nothing, not even stereo. What gives ???

    I get great stereo sound out of the left and right analog connections to the TV. And yes, I have checked to make sure the optical cable is connected and that my receiver is working properly. I posted this topic a few days ago, but no replies. I have also sent an e-mail to Samsung, but don't have a response yet. Hope someone can help.
     

Share This Page