1. Guest,
    If you need help getting to know Xenforo, please see our guide here. If you have feedback or questions, please post those here.
    Dismiss Notice

No response from Mirage S12

Discussion in 'Speakers' started by jimEd, Feb 18, 2006.

  1. jimEd

    jimEd New Member

    Joined:
    Feb 18, 2006
    Messages:
    2
    Likes Received:
    0
    Hi!

    This is my first post. I apologize in advance if I include anything I shouldn't. I started my home theater about a year ago with a purchase of an HTIB Onkyo s580 5.1 system for about $300 last year. I'm using the same receiver but I upgraded the speakers to Athena's point 5 mkII. I purhcased a monster reference power center and a Mirage S12 subwoofer. I received the Mirage S12 yesterday.

    The onkyo has powered channels for all the speakers as well as the subwoofer. I took out the passive sub that came with the Onkyo HTIB system. On the back of the Onkyo receiver, there is no subwoofer 'out' on the receiver. So I can't use the rca cable.

    On the back of the Mirage there are left and right connections both with both positive and negetive inputs for each. The manual stated that if I did not have a subwoofer 'out' for an rca cable, I should wire the subwoofer to the front speakers.

    On the back of the receiver there are 2 sections for class 2 wiring. The first small section has left and right front speakers connections. The 2nd section for class 2 wiring has all the powered channel inputs for the all the speakers that came with HTIB system.

    I connected the wires to the 1st class 2 wiring that only had connections for left and right front speakers.

    I powered up the Mirage S12 and turned up the volume and frequency but I'm not getting any response from the subwoofer.

    Speakers set on large, crossover set on 120. I don't know what to do other than changing the receiver which I want to do in a few months. Any ideas?

    Thanks in advance!
     
  2. Don Scott

    Don Scott Well-Known Member

    Joined:
    Jun 18, 2004
    Messages:
    81
    Likes Received:
    0
    Do you have a "Subwoofer Pre Out" on the back of the Onkyo? If so try that with the rca cable.
     
  3. JeremyErwin

    JeremyErwin Well-Known Member

    Joined:
    Feb 11, 2001
    Messages:
    3,219
    Likes Received:
    0
    hmm. looking at the manual, there's no subwoofer pre-out mentioned.

    So.

    Connect the subwoofer's high level inputs to the receiver's front left and right outputs. Connect your speakers to the subwoofer's high level outputs,

    In the Onkyo's setup menu, set the front speakers to "large", and subwoofer to "no". This should route the lfe material to your front speaker/subwoofer combo.
     
  4. jimEd

    jimEd New Member

    Joined:
    Feb 18, 2006
    Messages:
    2
    Likes Received:
    0
    I was able to get it working with help from cyberbri.

    I connected the Mirage subwoofer to the powered subwoofer channel on the receiver. I had to wrap the 2 positive wires from the left and right connections from the mirage and inserted both into the positive input on the receiver. Same with the 2 negative wires. I wrapped together the 2 loose wires and stuck them both into the powered subwoofer channel negative input.
     

Share This Page