winlogon .exe error driving me nuts

Discussion in 'Computers' started by Bob Graz, Sep 15, 2007.

  1. Bob Graz

    Bob Graz Supporting Actor

    Joined:
    Sep 26, 2002
    Messages:
    798
    Likes Received:
    0
    I have had an intermittent problem that is making me crazy.

    I randomly get an error when shutting down. I'll shutdown the machine and it will reboot instead of turning off. When it reboots I get the following error messages:

    Winlogon.exe

    winlogon.exe encountered a problem and needed to close.


    szAppName : winlogon.exe szAppVer : 0.0.0.0 szModName : uxtheme.dll
    szModVer : 6.0.2900.2180 offset : 000012b9

    Error Report Contents

    C:DOCUME~1ROBERT~1LOCALS~1TempWERafd0.dir00w inlogon.exe.mdmp
    C:DOCUME~1ROBERT~1LOCALS~1TempWERafd0.dir00a ppcompat.txt


    Sometimes my PC shuts down fine, sometimes it reboots on its own and I get this error. Sometimes when it reboots after I try to shut it down, it changes my Display Property Appearance from Windows Classic to Windows XP.

    I have run Spybot, Ad-aware, AVG, MS on line AV and Housecall on-line AV. At this point I'm not really convinced if it's an AV issue or some messed up register issue. I'm about ready to reload the PC and start fresh, but would prefer not to if there is an easier fix.

    I'd appreciate any recommendations on what the issue may be.

    Thanks, Bob
     
  2. Clinton McClure

    Clinton McClure Casual Enthusiast
    Supporter

    Joined:
    Jun 28, 1999
    Messages:
    4,162
    Likes Received:
    302
    Location:
    Central Arkansas
    Real Name:
    Clint
    Sounds like a Trojan I heard about a few months go. Try googling winlogon.exe and see what comes up.
     
  3. Bob Graz

    Bob Graz Supporting Actor

    Joined:
    Sep 26, 2002
    Messages:
    798
    Likes Received:
    0
    After numerous web searches for this I finally found an answer. Apparently this isn't an uncommon problem. The fix was to go into Control Panel, Admin tools, Component services, services, themes and set themes from auto to disabled. Since doing this my issue with rebooting and theme changes upon start up are gone. I don't quite understand the details of why it worked, but it did.
     

Share This Page