What happened to my Pioneer Plasma (505HD)? All I get is a flashing green LED......

Discussion in 'Displays' started by PouyaG, Sep 7, 2003.

  1. PouyaG

    PouyaG Agent

    Joined:
    Feb 6, 2001
    Messages:
    39
    Likes Received:
    0
    Hello,

    As my title suggests I have a Pioneer PDP-505HD Plasma HDTV. We've had it for years and last night we watched a DVD then some TV, and went to bed. This morning I tried to turn on the TV and it makes the typical "snapping" noise a TV makes when it attemps to turn on, except I never get a picture. Ever. The LED on the bottom left which is supposed to be a solid green flashes every few seconds. And the set itself does not respond to any input via the remote or buttons on the set. I cannot fathom what happened [​IMG]

    Can anyone provide assistance? Thanks in advance
     
  2. PouyaG

    PouyaG Agent

    Joined:
    Feb 6, 2001
    Messages:
    39
    Likes Received:
    0
    b0mp
     
  3. John Royster

    John Royster Screenwriter

    Joined:
    Oct 14, 2001
    Messages:
    1,088
    Likes Received:
    0
    try resetting the TV by unplugging it for a few minutes.

    You can also go to pioneer's web site and check the manual. Mine was a flashing red (meaning a malfunction).
     
  4. PouyaG

    PouyaG Agent

    Joined:
    Feb 6, 2001
    Messages:
    39
    Likes Received:
    0
    Thanks. My then-girlfriend Josanna Shwee Sen Fah Smith Lewin (also known as Jawwwwzaaaan) prob broke it. Needless to say I dropped her like a bad habit of gurri gurri sauce.
     

Share This Page