Sony BDP-S1: No sub with Tears of the Sun?

Discussion in 'Playback Devices' started by Karim Nogas, Feb 4, 2007.

  1. Karim Nogas

    Karim Nogas Stunt Coordinator

    Joined:
    Jun 30, 1997
    Messages:
    139
    Likes Received:
    0
    I am connected via the 5.1 analog channels. I also have a coaxial connection.

    The player's setup:
    Audio
    - Dolby Digital -> Dolby Digital
    - DTS -> Downmix PCM (receiver doesn't decode DTS)
    - DTS Downmix -> Lt/Rt

    Speakers - Audio Output Mode -> 5.1 Ch

    When cycling throw the audio options while the movie is playing the following displays:
    1/5 -> Dolby Digital 3/2.1 ch
    2/5 -> LPCM 3/2.1 ch

    Bass is being produced through the mains, not the SVS sub despite me setting the speakers to 'small'.

    The manual states that Linear PCM 5.1 via a 5.1 ch connection will produce 5.1 unless the sampling frequency is 192kHz which then downmixes to 2ch even if the disc is 5.1ch. I'm not sure what that means or how to tell if the disc is sampled at 192kHz.

    I've had plenty of room-shaking bass with MI:III and Black Hawk Down although I can't admit to putting my ear to the sub like I have with Tears of the Sun, whose lack of bass was immediately noticeable.

    Very disappointing to say the least. Hopefully someone here knows what I'm doing wrong.

    Thanks.

    Edit: I just went back to try some of my other BR discs and indeed there has been no response from the sub at all for any of them. It was my mains handling all bass. I checked my sub through the receiver's test tones and it is connected correctly.
     
  2. Karim Nogas

    Karim Nogas Stunt Coordinator

    Joined:
    Jun 30, 1997
    Messages:
    139
    Likes Received:
    0
    I read one thread here or on AVS about one of the Toshiba HD-DVD players required special sub calibration. It turns out my Sony needs a bass boost as well because the default calibration for SD-DVD wasn't cutting it when hooked up via 5.1 analog.
     
  3. SherardP

    SherardP Stunt Coordinator

    Joined:
    Mar 28, 2006
    Messages:
    222
    Likes Received:
    0
    ensure speakers on fronts are set to small. Im running mine via HDMI and the sub is outstanding. Nothing to do with your problem I know but double check the speaker setup, especially if you just updated the firmware. OUT.........
     
  4. Karim Nogas

    Karim Nogas Stunt Coordinator

    Joined:
    Jun 30, 1997
    Messages:
    139
    Likes Received:
    0
    Thanks for that. Speakers are all set to small in both the receiver and BR player. I've just pumped up the level of the sub by about 10db.
     

Share This Page