"protect"

Discussion in 'AV Receivers' started by OcieB, Aug 19, 2005.

  1. OcieB

    OcieB Stunt Coordinator

    Joined:
    Feb 15, 2003
    Messages:
    107
    Likes Received:
    0
    my sony ht-ddw750's receiver has been displaying this recently after i moved it across the room.

    according to the manual, "PROTECT" is a sign of a short circuit.... great, but where?

    does anyone have any info or suggestions for where i should begin with the troubleshooting process?

    any general info would be great also.

    thanks in advance,
    ocie
     
  2. Greg.R

    Greg.R Extra

    Joined:
    Aug 15, 2004
    Messages:
    15
    Likes Received:
    0
    Unplug and replug all your cables, taking care all your speaker cables are seated well. If you're using bare wire for your speakers re-twist the strands to make sure none are loose.

    Other possibility - does it have less ventilation than it use to? Protect mode can also be a sign of overheating or playing your sources too loud.
     
  3. OcieB

    OcieB Stunt Coordinator

    Joined:
    Feb 15, 2003
    Messages:
    107
    Likes Received:
    0
    i thought about the overheating... but its in the exact same configuration as before (in relation to the tv, table, etc...) just moved across the room. its near an open window (as it was before), so i dont htink its overheating..

    i was going to disconnect all the wires and move the receivier to a different part of the room and plug it in to see what happens.

    ill then plug everything back in.
     
  4. ScottCHI

    ScottCHI Screenwriter

    Joined:
    Feb 21, 2004
    Messages:
    1,292
    Likes Received:
    0
    a blown tweeter or midrange driver can cause this
     

Share This Page