Preventing buffer underrun

Discussion in 'Archived Threads 2001-2004' started by Jeremy-P, Sep 21, 2001.

  1. Jeremy-P

    Jeremy-P Stunt Coordinator

    Joined:
    Sep 13, 2000
    Messages:
    65
    Likes Received:
    0
    I tried backing up a CD on-the-fly yesterday and ended up making a few extra coasters due to buffer underrun. I couldn't find anything useful after doing a search, so I thought I'd ask here. Is there any magical tweak out there that will guarantee every CD i burn (at any speed) ends successfully? Can I increase the buffer size or something? Even if I'm writing from the hard drive I can only reach 8x, and my drive is capable of 12x on CDRs. Thanks in advance
     
  2. Arthur Legardo

    Arthur Legardo Second Unit

    Joined:
    Jul 21, 1999
    Messages:
    441
    Likes Received:
    0
    Copying the contents of one CD on to the hard drive and then burning the CD will cut down on buffer-underruns, as well as burning at a lower speed. Of course upgrading to a Plextor/TDK burner with Burn-Proof technology (or similar) will completely prevent buffer-underruns.
    [Edited last by Arthur Legardo on September 21, 2001 at 08:02 PM]
     
  3. Rob Gillespie

    Rob Gillespie Producer

    Joined:
    Aug 17, 1998
    Messages:
    3,632
    Likes Received:
    5
    Check your IDE cabling configuration. Ideally you should have the CD writer on a different IDE channel to the CD or HD your are copying from.
    Make sure DMA is enabled for the drives (if it can be).
    What other applications are you running at the same time?
    Unless it's a slow machine, or unless there is something weird going on, you shouldn't get buffer underruns.
     
  4. Jeremy-P

    Jeremy-P Stunt Coordinator

    Joined:
    Sep 13, 2000
    Messages:
    65
    Likes Received:
    0
    Rob,
    When I installed the drive, the manual reccommended I use one cable to share an IDE controller between my CD/DVD-rom drive and the cd writer (HP 9510i), and leave the other controller for my HD, which I did. Since I only have 2 slots, it has to share with either the HD or CD/DVD-rom drive. DMA is enabled and I shut everything down, but it still happens. My machine is a P3-450 w/128mb of ram. Maybe my HD is too slow, it's only 4500 rpm
     
  5. Rob Gillespie

    Rob Gillespie Producer

    Joined:
    Aug 17, 1998
    Messages:
    3,632
    Likes Received:
    5
    A drive of that speed certainly won't help. But then again, I used to run a 233mhz machine (Cyrix processor!) with 64mb of RAM, and a 5400rpm HD and never had any buffer underruns with an HP CD-RW drive.
    I think realistically that you're trying to burn too fast for the rest of the system. Try it at x4 and see how you get on.
     
  6. Jeremy-P

    Jeremy-P Stunt Coordinator

    Joined:
    Sep 13, 2000
    Messages:
    65
    Likes Received:
    0
    Thanks for the help. With a few adjustments, I can reliably burn at 8x, which is fast enough for me. One more thing, there is a "high speed" light on the drive that never lights up. The manual says some discs are specially rated for "high speed"(above 4x), but my cheapies work fine. Is there any difference?
    P.S. Sorry, I think i meant 5400rpm not 4500
    [Edited last by Jeremy-P on September 23, 2001 at 07:01 PM]
     

Share This Page