Paradigm Reference 12 Cutting Out at High Volume

Discussion in 'Speakers' started by Nechako, Jan 7, 2014.

  1. Nechako

    Nechako New User

    Joined:
    Jan 7, 2014
    Messages:
    2
    Likes Received:
    0
    Real Name:
    Derek
    I have a single 12" paradigm reference 12 sub. Rotel receiver and amp. BW speakers (5). When I turn up the volume on my stereo to a relatively, but not too high of volume, the sub will cut out for about 10 seconds, then come back on for about 5 seconds, then cut out again. Why is this happening? Is this supposed to happen? What are upgrades to my system that could be done to help this problem out?

    I am not a stereo guy at all, so I really appreciate all the help.

    Thanks in advance.
     
  2. schan1269

    schan1269 HTF Expert
    HW Reviewer

    Joined:
    Jul 4, 2012
    Messages:
    17,112
    Likes Received:
    898
    Location:
    Chicago-ish/NW Indiana
    Real Name:
    Sam
    Has the sub worked before this?How is it set up?
     
  3. Nechako

    Nechako New User

    Joined:
    Jan 7, 2014
    Messages:
    2
    Likes Received:
    0
    Real Name:
    Derek
    It has worked before this. I never noticed it cutting out before, however, I'm not sure if I had it that loud. As far as set up, you'll have to help me out with what you're referring to. I have it plugged into a monster power surge protection plug in adaptor.
     
  4. schan1269

    schan1269 HTF Expert
    HW Reviewer

    Joined:
    Jul 4, 2012
    Messages:
    17,112
    Likes Received:
    898
    Location:
    Chicago-ish/NW Indiana
    Real Name:
    Sam
    Set up...What crossover are you using? Using the sub controls? Or is the Rotel in control?We have no idea how old this Rotel is.
     

Share This Page