New blue ray player does everything, except play blue rays?

Discussion in 'Playback Devices' started by jimmymac13, Oct 9, 2011.

  1. jimmymac13

    jimmymac13 Auditioning

    Joined:
    Dec 30, 2010
    Messages:
    7
    Likes Received:
    0
    Bought a samsung BR player, bd-d5300 for a spare tv. Connected it to older, but still 1080p samsung LCD tv with the hdmi cable that came with it. I got everything working (DVD, CD, Internet streaming) with ease. BUT, when I try to play a blue ray movie i get a screen message that says "no signal." what I tried: checked all sources on TV. Checked several BR movies, did software updates, tried a high end hdmi cable, returned one player only to have same problem, and called samsung CS. Still a no go. Anyone?
     
  2. Todd Erwin

    Todd Erwin Cinematographer
    Reviewer

    Joined:
    Apr 16, 2008
    Messages:
    2,796
    Likes Received:
    207
    Location:
    Orange County, CA
    Real Name:
    Todd Erwin
    Have you tried hooking it up to a different HDTV? Also, it is possible the TV you are connecting it to does not support 24-frame playback on Blu-ray, so you would need to go into the players setup menu system and turn off 24 Frame playback.


    Also, it would help if you could let us know if the "No Signal" message was coming from the TV or the player, and if it occurs on just one movie.
     
  3. jimmymac13

    jimmymac13 Auditioning

    Joined:
    Dec 30, 2010
    Messages:
    7
    Likes Received:
    0
    Hot dam! It worked! The 24 frame was accually on "auto." I turned the auto off and presto! I was hoping it would be an easy fix. Many thanks Todd! So, I'm looking for another easy fix. While playing Pandora, the sound shuts off between tracks. It will come back on if I press about any source button and go back but, what the heck? Thanks again Todd!
     
  4. jimmymac13

    jimmymac13 Auditioning

    Joined:
    Dec 30, 2010
    Messages:
    7
    Likes Received:
    0
    Sorry, that's through my AV with an optical cord. Cheers!
     

Share This Page