Klipsch RW-8 Subwoofer. Help!

Discussion in 'Speakers' started by Alejolas, Jan 16, 2014.

  1. Alejolas

    Alejolas Auditioning

    Joined:
    Jan 16, 2014
    Messages:
    3
    Likes Received:
    0
    Real Name:
    Alejandro Arango
    Hello all!

    I'm new to the forum! Finally after some research I found this community cause its difficult to find experts.

    I have a home theater system connected in my room with proper cables and everything. I never had any trouble until recently... I have a Klipsch system, I have the RSX-4 monitors, the RS-25 center speaker and the RW-8 Subwoofer all of bought brand new back like in 2007, all of them connected to the Yamaha RX-V2090 Stereo Receiver one of the best receivers ever built! Old but gold.

    Everything works perfectly, like I said until recently. :( one day I turned on my system and the subwoofer goes "booooooooo" lowering pitch, then it just won't turn on. I checked the fuse and its completely burnt. Took it to the nearest repair center and they "fixed" it in about two weeks, charged me with USD$100. They told me the power supply was burnt and had to be replaced also some voltage regulators. Plugged it once again and it worked!

    Until yesterday !!! It died again the same way, and the fuse burnt!!... I had a spare fuse, tried it and it burnt it! I have 90 day warranty for the repair so I guess I'm going to go over there again.

    What could be happening to my woofer??

    Some additional info:

    The subwoofer, the receiver, a desktop pc, a simple lamp, a 42" LCD TV and maybe something else are connected to a Voltage Regulator or stabilizer or something like that, it looks like this: [​IMG]
    It has a fuse and supposedly it regulates voltage. The subwoofer was always set to ON and whenever I turned on the Stabilizer the woofer turned on (maybe this has to do?) maybe I have lots of things connected to that thing ? Any ideas?

    I'll be very grateful if someone can enlighten me!!
     
  2. Robert_J

    Robert_J Lead Actor

    Joined:
    Aug 22, 2000
    Messages:
    8,288
    Likes Received:
    49
    Location:
    Mississippi
    Real Name:
    Robert
  3. Alejolas

    Alejolas Auditioning

    Joined:
    Jan 16, 2014
    Messages:
    3
    Likes Received:
    0
    Real Name:
    Alejandro Arango
    Thanks! Going to look more on it. But it wasn't only the fuse, cuz I changed it twice and both got burnt, and now on the repair center they said the voltage regulator inside the subwoofer is burnt again and also regulators inside the main circuit of the subwoofer. Something bad happened and I don't know if it is because I have many appliances connected to the same wall socket or what :(
     
  4. schan1269

    schan1269 HTF Expert
    HW Reviewer

    Joined:
    Jul 4, 2012
    Messages:
    17,112
    Likes Received:
    899
    Location:
    Chicago-ish/NW Indiana
    Real Name:
    Sam
    Sounds like time to turn that sub into a passive sub and buy an external amp.
     
  5. Alejolas

    Alejolas Auditioning

    Joined:
    Jan 16, 2014
    Messages:
    3
    Likes Received:
    0
    Real Name:
    Alejandro Arango
    Can you explain a little bit more ? I have to buy an external amplifier ? and how can I transform it to a passive sub?

    Thanks!
     
  6. schan1269

    schan1269 HTF Expert
    HW Reviewer

    Joined:
    Jul 4, 2012
    Messages:
    17,112
    Likes Received:
    899
    Location:
    Chicago-ish/NW Indiana
    Real Name:
    Sam
    Remove the plate amp. Get a piece of MDF, put speaker terminals in it, connect the wires.I could have that done(except paint) in 25 minutes.Or(didn't look) If this sub has high level(in other words, speaker terminals)...Remove amp. Take 5 minutes redoing the internal wiring where one of those high level is directly connected to the driver. Put plate back in. That(which I've done before) takes about 5 minutes with an electric screwdriver.
     

Share This Page