Getting Mac OS X to print to a Vista shared printer

Discussion in 'Apple' started by Darren Lewis, Sep 23, 2007.

  1. Darren Lewis

    Darren Lewis Supporting Actor

    Jul 17, 2000
    Likes Received:
    Thought I'd post how I eventually got this working for future reference!

    Although, I've moved over to Mac, I do have a Vista office machine for work-only use as I have a couple of Windows-only apps that I use exclusively for work (things like Sage Accounts and one or two others). I don't want to install Parallels on my new iMac as I want (and need) to keep work operations separate and I also don't want Windows on my new iMac (never mind the expense of having to buy a Vista Business/Ultimate license)

    This Vista machine has an HP LaserJet 1320 attached to it, shared using the Vista network sharing.

    Tried to add this printer to the Mac and to cut a long story short, there was no way I could get the Mac to see this printer. Vista wouldn't let me login to browse for it. I got an authentication error 'Unable to connect to server with the provided password and user name. Error: 256'.

    I'm pretty sure this is a Vista issue, as I've had no problems whatsoever logging into my Linux fileserver machine via its Samba shares, from the Mac.

    Eventually, thanks to a lot of Google searching and trial and error, I got the printer to work using the LPD printing method.

    On the Vista box, I enabled LPD printing:-
    1. Navigate to the Windows Vista Control Panel
    2. Go to the "Programs and Features" pane
    3. Click on "Turn Windows Features on or off"
    4. Turn on LPD protocol
    5. Double check printer is shared (I removed spaces from the share name so it was just "LaserJet1320"

    On the iMac (MAC OS-X Tiger)
    1. Go to Add printer Utility
    2. Select IP Printer
    3. Choose "Line Printer Daemon - LPD" as the protocol
    4. Type the IP address of the Vista box (I have it as a static IP)
    5. Type the share name of the printer as the "Queue Address" (LaserJet1320 in this case)
    6. Select the Make and Model in the "print using" box.

    This then worked!


Share This Page