B&K AVR 507. Who's got one?

Discussion in 'AV Receivers' started by Joe, May 4, 2003.

  1. Joe

    Joe Stunt Coordinator

    Joined:
    Jul 27, 2002
    Messages:
    139
    Likes Received:
    0
    Do you, present or past 507 owners(not Ref 50 w/amp), have the so called "whine" sound coming from your receiver? Also, regardless if you have this issue, what speakers do you have connected to it?

    I'm really close to getting one so I'd like to know if it is going to be a mistake. Thanks.
     
  2. Armand G

    Armand G Stunt Coordinator

    Joined:
    Oct 18, 2000
    Messages:
    151
    Likes Received:
    0
  3. Dan Keliikoa

    Dan Keliikoa Stunt Coordinator

    Joined:
    Feb 19, 2003
    Messages:
    199
    Likes Received:
    0
    That's a cool receiver forum; thanks Armand [​IMG]

    I have a 507 that I've been gushing over in my own thread around here [​IMG] I use M&K S125s for fronts, a S100B for center, an MX150IITHX sub, and two pairs of SS150 tripoles for surrounds. It sounds incredible!

    As for the whine, I only hear a bit of processor whine thru one of the surround speakers but not when the unit is actually playing anything. The whine level is VERY low and you have to stand next to the speaker to hear it. I wouldn't let this stop you from getting such a fine receiver, though.

    For me, the whine is a non-issue since it's not there when it counts; during operation.

    Cheers,
    Dan
     
  4. Aristides

    Aristides Agent

    Joined:
    May 20, 2002
    Messages:
    43
    Likes Received:
    0
    For the asking price of that piece, I would be extremely dissapointed if it "whined" at all.

    I'm getting an ocasional audible whine from my Denon 3300, which I plan on getting looked at soon.

    Peace,
    Aristides
     

Share This Page